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Preface 
This manual describes the main functionality delivered by the CATIA Teamcenter 
Interface (CMI RII) and includes the creation, storage, modification, and management of 
CATIA models and assembly structures in the Teamcenter PDM system. 

 

About this Manual 

This manual is intended for end users of the CATIA Teamcenter Interface. It assumes that 
the reader is familiar with the CATIA application and with Teamcenter Rich Client. 

 

Related Documents 

The following manuals contain information about installation, usage and customization of 
the CATIA Teamcenter Interface: 

 
Manual Title Version 

CATIA Teamcenter Interface RII Installation Manual 4.9 
CATIA Teamcenter Interface RII Customizing Manual 4.9 

 

Organization 

This manual contains the following chapters: 

Chapter 1 provides basic information about the CATIA Teamcenter Interface and 
describes some features of this application interface. 

Chapter 2 describes how to start CATIA within the Teamcenter environment and also how 
to enable the CMI functionality within CATIA V5. 

Chapter 3 introduces the CMI RII Application with a general explanation and then by 
listing its functions. The goal of this chapter is to make the user familiar with this 
component. The CMI RII Application functions will be explained in subsequent chapters. 

Chapter 4 describes how to handle CATIA relevant data in Teamcenter. 

Chapter 5 explains how to work with CATIA V5. 

Glossary contains the CATIA Teamcenter Interface terminology. 
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Conventions Used in this Manual 

This font Is used for document titles and emphasis. 

 

Item 1→Item 2 Is used to identify a menu path to reach a specific function. 

 

 
This icon is used to identify tips and attention advises. 

 

 

This icon is used to identify Teamcenter related sections and actions. 

 

 

This icon is used to identify CATIA V5 related sections and actions. 

 

Your Comments are Welcome 

Please feel free to tell us your opinion; we are always interested in improving our 
publications. Mail your comments to: 

T-Systems International GmbH 
Business Unit PLM 
Fasanenweg 5 
70771 Leinfelden-Echterdingen 
Germany 

E-mail: cmi_support@t-systems.com 
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CHAPTER 1 

Overview  
This chapter provides basic information about the CATIA Teamcenter Interface and lists 
some features of this application interface. 

 

Introducing CMI (CATIA Teamcenter Interface) 

The CATIA Teamcenter Interface (CMI RII) was developed by T-Systems as a high-end 
integration between the CAD system CATIA V5 and the PDM system Teamcenter. With 
this interface it is possible to manage CATIA V4 and CATIA V5 models and assemblies in 
Teamcenter and CATIA V5. 

CATIA V5 uses assemblies similar to Teamcenter. CMI RII makes a bidirectional mapping 
between the Teamcenter structure and the CATIA V5 structure. So users have the full 
functionality of Teamcenter and CATIA V5. 

 

CMI RII joins the advantages of CAD with PDM 

The CATIA Teamcenter Interface combines the CAD Excellency of CATIA with the power 
of the PDM system Teamcenter. It provides the user with a more sophisticated way of 
working with CATIA by allowing the management of product structures and multiple level 
assembly structures within the PDM system. 

The CATIA Teamcenter Interface (CMI RII) permits: 

▪ Integration of CATIA data in workflow (e.g. release control); 

▪ Management of CATIA data in vaults, without knowledge about the underlying file 
system; 

▪ Updating concurrent engineering processes by different users; 

▪ Distribution of CATIA data in a network; 

▪ Simultaneous management of CATIA data and structures; 

▪ Construction of part structures within Teamcenter; 

▪ Modification of the position of the structures; 

▪ Search for CATIA data by different attributes. 
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CMI Architecture 

The following figure explains the architectural basics of the CATIA Teamcenter Interface 
(CMI RII). 

 

 

Figure 1: CATIA Teamcenter Interface architecture 

The user can expand an assembly within the CMI RII application and send this assembly 
to CATIA V5. After changing geometries and/or positions in CATIA the user can update 
the assembly in Teamcenter. 

The CMI RII application is not available with Teamcenter 2007. The main functionality can 
be used similar with the PSE application. 

 

CMI RII Application in Teamcenter CATIA V5 with CMI RII 
Toolbar 

Network 
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CHAPTER 2 

Getting Started 
This chapter describes how to start CATIA within the Teamcenter environment and also 
how to enable the CMI functionality within CATIA V5. 

 

Assumptions 

Some assumptions, for a better understanding of the descriptions and examples: 

 

CATIA V5 should display the two CMI toolbars: 

   

 

UNIX: 
Start CATIA V5 with the command cmicatstart.sh 

Windows:  
Make sure you have set up the right environment (refer to the CATIA Teamcenter 
Interface RII Installation Manual). Launch CATIA V5 with the command: 
CNEXT.exe  -env CatiaCMIEnv -direnv "C:\<path to the CMIEnv>" 

 

Starting Applications 

Before working with CMI RII it is necessary to start the Teamcenter Rich Client, the 
Teamcenter user interface, and the CATIA V5. 

For information on starting Teamcenter Rich Client see the Teamcenter Help Library – 
Getting Started with Teamcenter provided by Siemens PLM. 

For information on starting the CATIA User Interface see the CATIA Solutions User’s 
Guide. 

 
It makes no difference if Teamcenter or CATIA is started first. 

 

Enabling the CMI toolbar in CATIA V5  

 

In CATIA V5, select the menu View→Toolbars→CMI and View→Toolbars→CMI 
Advanced Tools. 



 

4 CMI RII Release 4.9 - User Manual  

 

If the CMI toolbars are not in the list of toolbars, a problem with the installation may 
have occurred. In this case, contact the administrator. Information about this kind of 
problem can be found in the CATIA Teamcenter Interface RII Installation Manual. 
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CHAPTER 3 

The CMI RII Application 
This chapter introduces the CMI RII application with a general explanation and then by 
listing its functions. The goal of this chapter is to make the user familiar with this 
component. The CMI RII application functions will be explained in subsequent chapters. 

The CMI RII application is not available with Teamcenter 2007. The main functionality can 
be used similar with the PSE application. 

 

What is the CMI RII Application? 

The CMI RII application is a Teamcenter application used to interactively prepare an 
assembly structure for sending to CATIA and to provide several manipulation facilities for 
the CMI commands found in CATIA. The entire data interchange between Teamcenter 
and CATIA is achieved via the CMI RII application. 

CMI RII defines some new dataset types in Teamcenter that can be used to manage 
CATIA V5 files (CATPart, model, cgr, CATProduct, and CATDrawing). The management 
of CATIA V5 files is described in Chapter 5. 

To start the CMI RII application use the standard Teamcenter start mechanism as shown 
in Figure 2. 

 

Figure 2: Teamcenter Rich Client start window 

A window with the CMI RII application will appear after logging in into the PDM system 
Teamcenter (see Figure 3). 
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Figure 3: CMI RII application window 

 

The CMI RII Application Menu 

Below the CMI RII application menu items will be described. 

 

Figure 4: CMI RII application menu items 

Menu item File 

 

Figure 5: CMI RII application menu ‘File’ 

The menu item File→Close will close the CMI RII application. 

The menu item File→Exit will exit the Rich Client application. 

Menu item Edit 

 

Figure 6: CMI RII application menu ‘Edit’ 
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The menu item Edit→User Setting… will open the User Setting dialog of the Rich Client 
application. 

The menu item Edit→Options… will open the Preferences dialog of the Rich Client 
application. 

The CMI RII options are shown on a separate tabular (see Figure 7). 

Send To CATIA 

Send drawings to CATIA? Checked if drawing files (CATDrawing) should be 
sent to CATIA. 

Send cgms to CATIA? Checked if cgm files should be sent to CATIA. 

Send visualization files to CATIA? Checked if visualization files should be sent to 
CATIA. 

Send analysis files to CATIA? Checked if analysis files should be sent to CATIA. 

Transfer CGR files To CATIA 

No No CGR are sent to CATIA 

Only CGR If a read-only CATPart / V4 model (the file is not 
checked out by the session user) has a 
corresponding cgr file, CMI RII transfers only the 
CGR file to CATIA.  

For a writable CATPart / V4 model (the file is 
checked out) CMI RII transfers the CATPart / V4 
model file, too. 

CGR + geometry CGR and geometry files are sent to CATIA 

Work with CATIA Version 

V5 work with CATIA V5 

V4 work with CATIA V4 

Read Mode for Read From CATIA 

Use Standard Read Mode Send the visible (expanded) children to CATIA. 

Use DMU Read Mode Send the DMU marked (checked) children to 
CATIA. 

Use Automatic Read Mode Use DMU Read Mode if the Viewer is active, use 
Standard Read Mode if the Viewer is not active. 

Newstuff Setting 

It can be defined for new Items and Datasets to which folder they should be linked after 
create. 

Newstuff Folder The default Newstuff Folder will be used. 

Folder Selection The link folder is chosen by the user (It is not 
possible to create a new folder in this dialog). 

None Do not link new objects to a folder. 

DMU Settings 

DMU Clearance [mm] Define the DMU Clearance for the Neighbourhood 
search and Volume search functions. 
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Figure 7: The CMI RII options dialog 

Menu item Tools 

 

Figure 8: CMI RII application menu ‘Tools’ 

The menu item Tools→Send To CATIA starts the Read To CATIA action and will read the 
CMI RII application content to the CATIA. 

The menu item Tools→Temp To CATIA starts the Add Temp To CATIA action and will 
read the temporary added items to the CATIA. This menu item is only usable if the Add 
Temp action is started from the CATIA. 

The menu item Tools→Insert/Replace To CATIA starts the Insert/Replace To CATIA 
action and will read the queried items to the CATIA. This menu item is only usable if the 
Insert from Teamcenter action or the Replace from Teamcenter action is started from the 
CATIA. 

The menu item Tools→Cancel CATIA Action cancels actions which are started from 
CATIA (e.g. SaveAs and AddTemp). This menu item is only usable if an action is started 
from the CATIA (e.g. SaveAs and AddTemp). 

The menu item Tools→Clear Workbench removes all items from the CMI RII application 
window. 

The menu item Tools→Volume Search … starts the Volume Search (see CMI RII→ 
Volume Search page 15). 

The menu item Tools→Neighbourhood Search starts the Neighbourhood Search (see CMI 
RII→ Neighbourhood search page 17). 
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Menu item Window 

 

Figure 9: CMI RII application menu ‘Window’ 

The menu item Window includes the standard menu items provided by the Teamcenter 
Rich Client application. 

Menu item Help 

 

Figure 10: CMI RII application menu ‘Help’ 

The menu item Help points to the standard application Help provided by the Teamcenter 
Rich Client application. 

The menu item Help→About opens the About dialog. 

The About dialog informs about the actual CMI RII application (see Figure 11). 

 

Figure 11: CMI RII application About dialog.  
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Pop-Up menus of CMI RII Items 

If you select an Item and drop it into, or Send it to the CMI RII application, a BOMLine will 
be created dynamically. Items which will be handled as geometry items are represented 

by , structure elements are represented by .  

If you select a Drawing dataset and drop it into, or Send it to the CMI RII application a 

dataset is shown in the CMI RII application. The Drawing dataset is represented by . 

If you select a cgm dataset and drop it into, or Send it to the CMI RII application a dataset 

is shown in the CMI RII application. The cgm dataset is represented by . 

Items in the CMI RII Application 

On the Item objects displayed in the CMI RII application window there are the following 
functions available: 

 

Figure 12: Context menu on a Line in the CMI RII application 

 
The Remove from Window command only works on selected top level elements. 

 

Remove from Window Removes the selected object from the CMI RII 
application window. 

Highlight in CATIA Highlights the selected objects in CATIA. 
Refresh Refreshes the selected object from the database. 

Expand Expands the object one level. 
Expand Below Expands the object multiple levels. 
Expand Below… Expands the object multiple levels, a dialog will be 

displayed where the level number can be defined. 
Collapse Below Collapses all children. 

Expand for Visualization Expands the object multiple levels with the 
visualization option. 
When a visualization model is found the expand 
stops and only the Visualization model will be sent to 
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CATIA. 

Neighbourhood Search Starts the Neighbourhood Search for the selected 
items. 

Pack Pack the selected lines. 
Unpack Unpack the selected lines. 

Copy Copies the selected object to the clipboard. 

Send To Sends the selected object to another Teamcenter 
application. 

Properties Displays the Teamcenter properties dialog. 

Add To Favorites Adds the selected object to the favorites list on the 
left. 

Models in the CMI RII Application 

On the Dataset (CATDrawing, Auxiliary geometries, CMIArchives and cgm) objects 
displayed in the CMI RII application window there are the following functions available: 

 

Figure 13: Context menu on a Dataset in the CMI RII application 

Remove from Window Removes the selected object from the CMI RII 
application window. 

Deexpand Model Deexpands the selected objects from the CMI 
RII application window. 

Copy Copies the selected object to the clipboard. 

Send To Sends the selected object to another Teamcenter 
application. 

View Properties Displays the Teamcenter properties dialog. 

Add To Favorites Adds the selected object to the favorites list on the 
left. 

 

Single Model handling in the CMI RII Application 

CATDrawing, CATAnalysis and cgm Models can be separately expanded in the CMI RII 
application if the global "Send To CATIA" preferences are not checked (see Figure 14). 
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Figure 14:CMI RII Send To CATIA Preferences 

If the “Send drawings to CATIA?”, “Send cgms to CATIA?” or “Send analysis files to 
CATIA?” preference is not selected, these dataset types can be expanded in the CMI RII 
application window with the corresponding context menu. 

 
The context menus (see Figure 15) are not visible, if the global preferences (see 
Figure 14) are checked. 

 

 

Figure 15:Extended context menu on a Line in the CMI RII application 

The expanded Model will be loaded to CATIA if it is visible and checked. 

The model can be deexpanded with the Deexpand Model command in the context menu 
(see Figure 16), or if the parent node is normally expanded. 

 

Figure 16:Expanded model with context menu 
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Enhancements in the Structure 
Manager Application 
This section introduces the enhancements in the Structure Manager application by listing 
its functions. 

 

CMI RII Menu bar in the Structure Manager Application 

The Structure Manager application menu is enhanced by a new CMI RII menu item (see 
Figure 17). 

 

Figure 17: Structure Manager application with CMI RII menu 

Menu item CMI RII 

The menu item CMI RII (see Figure 18) contains three commands to send data to CATIA. 
The next three commands are used to send data which was requested by CATIA or to 
cancel the CATIA action. The last two commands are used to search in the geometry. 

 

Figure 18: Structure Manager menu ‘CMI RII’ 

CMI RII→ Send To CATIA 

The menu item CMI RII→Send To CATIA will send the expanded Structure Manager 
content to CATIA. 

 

The Send To CATIA command will send the content of the current active Structure 
Manager application window to CATIA. Only expanded structures will be sent to 
CATIA. Unexpanded structures will not be sent to CATIA. 
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Figure 19: Structure Manager application with Send To CATIA command 

Only the expanded structures from the example structure in Figure 19 will be sent to 
CATIA. The items FixedParts and PistonComplete are not expanded and the 
substructures of these items are not sent to CATIA. 

CMI RII→Send DMU To CATIA 

The menu item CMI RII→Send DMU To CATIA will send the DMU ‘marked’ Structure 
Manager content to CATIA. 

 

The Send DMU To CATIA command will send the checked content (checkboxes are 
presented by the viewer functionality) of the current active Structure Manager 
application window to CATIA. Only checked structures will be sent to CATIA. 
Unchecked structures will not be sent to CATIA. 

 

Figure 20: Structure Manager application with Send DMU To CATIA command 
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Only the checked items from the example structure in Figure 20 will be sent to CATIA. The 
unchecked structures FixedParts and PistonComplete will not be sent to CATIA. 

CMI RII→ Send Selected To CATIA 

The menu item CMI RII→Send Selected To CATIA will send the selected objects of the 
expanded Structure Manager content to CATIA. 

 

The Send Selected To CATIA command will send the selected objects of the current 
active Structure Manager application window to CATIA. 

 

Figure 21: Structure Manager application with Send Selected To CATIA command 

Only the selected objects of the example structure in Figure 21 will be sent to CATIA. The 
items CrankBolt, CrankShaftLeft and CrankShaftRight are selected and will be sent to 
CATIA. 

CMI RII→Temp To CATIA, CMI RII→Insert/Replace To CATIA, CMI RII→Cancel CATIA Action 

For details see Chapter Working with CATIA V5. 

CMI RII→ Volume Search... 

The menu item CMI RII→Volume Search... provides a volume search in the Structure 
Manager application. 

The search is based on the bounding box information stored from CATIA in Teamcenter. 

 

The administrator needs to set CMI_CALC_BBOX=ON in the CATIA environment in 

order to enable the Bounding Box functionality. 

With set CMI_CALC_BBOX_FOR_IGNOREDCHILDREN=ON in the CATIA 

environment the Bounding Box functionality for ignored children (not existing in 
Teamcenter) can be switched on. For details please see the customization manual. 

Optional: CMI_BOUNDING_BOX_EXCLUDE_HIDDEN=ON 

 

Select a volume by defining 2 points which define a cuboid in the global coordinate system 
as search criteria (see Figure 22). 
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Figure 22: Volume definition Dialog 

The DMU clearance can be set in the CMI RII options panel (see Figure 23). 

  

Figure 23: CMI RII preferences panel 

After defining the search criteria the structure is searched for bounding box information 
which is stored in the following dataset types: 

• CMI2Part, CMI2Model, CMI2Cgr, CMI2Rep, 

• CMI2AuxPart, CMI2AuxModel, CMI2AuxCgr, and CMI2AuxRep, CMIArchive 

The Volume Search and the Neighbourhood Search command computes the result and 
selects the lines in the Structure Manager. This result can then be sent to CATIA V5 using 
the command Send selected To CATIA (see Figure 24). 
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Figure 24: Selected result lines in Structure Manager 

CMI RII→ Neighbourhood search 

The menu item CMI RII→Neighbourhood search provides a neighbourhood search in the 
Structure Manager application. 

The search is based on the bounding box information stored from CATIA in Teamcenter. 

 

The administrator needs to set CMI_CALC_BBOX=ON in the CATIA environment in 

order to enable the Bounding Box functionality.  

With set CMI_CALC_BBOX_FOR_IGNOREDCHILDREN=ON in the CATIA 

environment the Bounding Box functionality for ignored children (not existing in 
Teamcenter) can be switched on. For details please see the customization manual. 

Optional: CMI_BOUNDING_BOX_EXCLUDE_HIDDEN=ON 

 

Select one or more lines in the Structure Manager application. The bounding boxes of the 
selected lines (see Figure 25) are used as search criteria. 
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Figure 25: Neighbourhood Search 

The search results are selected in the Structure Manager application and can be sent to 
CATIA V5 using the command Send selected To CATIA (see Figure 24) 

Highlight in CATIA 

This action is only available with Teamcenter 2007 in this menu. For details see Chapter 
Highlighting an Item in CATIA on page 48. 

About CMI RII 

This action opens a dialog which shows you the version of the installed CMI RII package. 

 

 



 

CMI RII Release 4.9 - User Manual  19 

Enhancements in the Multi-
Structure Manager Application 
This section introduces the enhancements in the Multi-Structure Manager application by 
listing its functions. 

 

CMI RII Menu bar in the Multi-Structure Manager Application 

The Multi-Structure Manager application menu is enhanced by a new CMI RII menu item 
(see Figure 26). 

 

Figure 26: Multi-Structure Manager application with CMI RII menu 

Menu item CMI RII 

The menu item CMI RII (see Figure 27) contains two commands to send data to CATIA. 
The next three commands are used to send data which was requested by CATIA or to 
cancel the CATIA action. 

 

Figure 27: Multi-Structure Manager menu ‘CMI RII’ 

CMI RII→ Send To CATIA 

The menu item CMI RII→Send To CATIA will send the expanded Multi-Structure Manager 
content to CATIA. 

 

The Send To CATIA command will send the content of the current active Multi-
Structure Manager application window to CATIA. Only expanded structures will be 
sent to CATIA. Unexpanded structures will not be sent to CATIA. 
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Figure 28: Multi-Structure Manager application with Send To CATIA command 

Only the expanded structures from the example structure in Figure 28 will be sent to 
CATIA. The items FixedParts and PistonComplete are not expanded and the 
substructures of these items are not sent to CATIA. 

CMI RII→Send DMU To CATIA 

The menu item CMI RII→Send DMU To CATIA will send the DMU ‘marked’ Multi-
Structure Manager content to CATIA. 

 

The Send DMU To CATIA command will send the checked content (checkboxes are 
presented by the viewer functionality) of the current active Multi-Structure Manager 
application window to CATIA. Only checked structures will be sent to CATIA. 
Unchecked structures will not be sent to CATIA. 

 

Figure 29: Multi-Structure Manager application with Send DMU To CATIA command 
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Only the checked items from the example structure in Figure 29 will be sent to CATIA. The 
unchecked structures FixedParts and PistonComplete will not be sent to CATIA. 

CMI RII→Temp To CATIA, CMI RII→Insert/Replace To CATIA, CMI RII→Cancel CATIA Action 

For details see Chapter Working with CATIA V5. 

Highlight in CATIA 

This action is only available with Teamcenter 2007 in this menu. For details see Chapter 
Highlighting an Item in CATIA on page 48. 

About CMI RII 

This action opens a dialog which shows you the version of the installed CMI RII package. 
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Enhancements in the 
Manufacturing Process Planner 
Application 
This section introduces the enhancements in the Manufacturing Process Planner 
application by listing its functions. 

 

CMI RII Menu bar in the Manufacturing Process Planner Application 

The Manufacturing Process Planner application menu is enhanced by a new CMI RII 
menu item (see Figure 30). 

 

Figure 30: Manufacturing Process Planner application with CMI RII menu 

Menu item CMI RII 

The menu item CMI RII (see Figure 31) contains two commands to send data to CATIA. 
The next three commands are used to send data which was requested by CATIA or to 
cancel the CATIA action.  

 

Figure 31: Manufacturing Process Planner menu ‘CMI RII’ 

CMI RII→ Send To CATIA 

The menu item CMI RII→Send To CATIA will send the expanded Manufacturing Process 
Planner content to CATIA. 

 

The Send To CATIA command will send the content of the current active 
Manufacturing Process Planner application window to CATIA. Only expanded 
structures will be sent to CATIA. Unexpanded structures will not be sent to CATIA. 
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Figure 32: Manufacturing Process Planner application with Send To CATIA 
command 

Only the expanded structures from the example structure in Figure 32 will be sent to 
CATIA. The items FixedParts and PistonComplete are not expanded and the 
substructures of these items are not sent to CATIA. 

CMI RII→Send DMU To CATIA 

The menu item CMI RII→Send DMU To CATIA will send the DMU ‘marked’ Manufacturing 
Process Planner content to CATIA. 

 

The Send DMU To CATIA command will send the checked content (checkboxes are 
presented by the viewer functionality) of the current active Manufacturing Process 
Planner application window to CATIA. Only checked structures will be sent to 
CATIA. Unchecked structures will not be sent to CATIA. 
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Figure 33: Manufacturing Process Planner application with Send DMU To CATIA 
command 

Only the checked items from the example structure in Figure 33 will be sent to CATIA. The 
unchecked structures FixedParts and PistonComplete will not be sent to CATIA. 

CMI RII→Temp To CATIA, CMI RII→Insert/Replace To CATIA, CMI RII→Cancel CATIA Action 

For details see Chapter Working with CATIA V5. 

Highlight in CATIA 

This action is only available with Teamcenter 2007 in this menu. For details see Chapter 
Highlighting an Item in CATIA on page 48. 

About CMI RII 

This action opens a dialog which shows you the version of the installed CMI RII package. 
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Enhancements in the 
My Teamcenter Application 
This section introduces the enhancements in the My Teamcenter application by listing its 
functions. 

 

CMI RII Menu bar in the My Teamcenter Application 

The My Teamcenter application menu is enhanced by a new CMI RII menu item (see 
Figure 34). 

 

Figure 34: My Teamcenter application with CMI RII menu 

Menu item File 

The Menu item File (see Figure 35) contains new types “CATIA BOM Part Item”, “CATIA 
AUX Part Dataset”, “CATIA Product Item”, and “CATIA Drawing Dataset” in the sub menu 
“New”. 

 

Figure 35: My Teamcenter menu ‘File’ 
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File→New→CATIA BOM Part Item 

Please see the description of the action CMI RII→Create→CATIA BOM Part Item on page 
32. 

File→New→CATIA AUX Part Dataset 

Please see the description of the action CMI RII→Create→CATIA AUX Part Dataset on 
page 33. 

File→New→CATIA Product Item 

Please see the description of the action CMI RII→Create→CATIA Product Item on page 
34. 

File→New→CATIA Drawing Dataset 

Please see the description of the action CMI RII→Create→CATIA Drawing Dataset on 
page 34. 

Menu item CMI RII 

The Menu item CMI RII (see Figure 36) contains one command to send data to CATIA. 
The next three commands are used to send data which was requested by CATIA or to 
cancel the CATIA action.  

 

Figure 36: My Teamcenter menu ‘CMI RII’ 

CMI RII→Send To CATIA 

The menu item CMI RII→Send To CATIA will send the selected objects in My Teamcenter 
to CATIA. 



 

CMI RII Release 4.9 - User Manual  27 

 

Figure 37: My Teamcenter application 

 

The Send To CATIA command will send the selected objects (see Figure 37) of the 
current active My Teamcenter application window to CATIA. Only datasets for 
CATDrawing, cgms or auxiliary geometry and Item Revisions with BOM geometry 
are supported. 

CMI RII→Send Configured To CATIA 

The menu item CMI RII→Send Configured To CATIA will send the selected Item Revision 
from My Teamcenter with the chosen Revision Rule and Variant to CATIA. 

 

Select the Item Revision and use the CMI RII→Send Configured To CATIA 
command. 

A dialog will be opened (see Figure 38). In the dialog you can select the Revision 
Rule and the Variant (StoredOptionSet or VariantRule) for the selected Item 
Revision. If no Variant is found the Variant option is disabled. 

After clicking the OK button the expand is performed and the structure is sent to 
CATIA. 

 

Figure 38: Send Configured To CATIA dialog 

CMI RII→Send SaveAs To CATIA 

The menu item CMI RII→Send SaveAs To CATIA will send the selected My Teamcenter 
object to CATIA. 

 

Design or load your CATPart, CATDrawing or cgm in a separate window in CATIA. 
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In CATIA V5 select the Save As in Teamcenter icon . 

 

Select an item in the My Teamcenter application in Teamcenter. 

In order to Save As in Teamcenter with a CATDrawing, select the ‘new’ CATDrawing 
dataset to be overwritten in the My Teamcenter application in Teamcenter. The 
CATDrawing active in CATIA V5 will then overwrite its content. 

In order to Save As in Teamcenter with a cgm, select the ‘new’ cgm dataset to be 
overwritten in the My Teamcenter application in Teamcenter. The cgm active in 
CATIA V5 will then overwrite its content. 

In order to Save As in Teamcenter with a BOM CATPart, select the ‘new’ item to be 
overwritten in the My Teamcenter application in Teamcenter. The CATPart active in 
CATIA V5 will then overwrite its content. 

In order to Save As in Teamcenter with a no BOM CATPart, select the ‘new’ 
auxiliary dataset to be overwritten in the My Teamcenter application in Teamcenter. 
The CATPart active in CATIA V5 will then overwrite its content. 

 

Select the menu item CMI RII→Send SaveAs To CATIA. 

 

Please take care when you ‘Save As’ a CATPart which is used in a CATProduct - a 
reference to the CATPart is stored within the parent CATProduct. Make sure that the 
new CATPart is compatible. 

CMI RII→Temp To CATIA 

The menu item CMI RII→Temp To CATIA will send the selected My Teamcenter object to 
CATIA. 

 

In CATIA V5, go to Tools→Options→Compatibility (Tab: “CMI”) and make sure that 
the option “Use one temporary product window…” is checked. 

 

Read an assembly into CATIA using the Read command in CMI toolbar. 

In CATIA V5 select the AddTemp from Teamcenter icon 

 

. 

 

Select the BOM CATPart, no BOM CATPart, or CATDrawing you want to add 
temporarily to CATIA into the CMI RII application. Click CMI RII→Temp To CATIA in 
the menu. 

 

CATIA comes to the foreground with both the original and temporarily added objects 
loaded in the same window. 

It will not be possible to make any changes to the temporarily added object. 

 

All Part Numbers and File Names of the temporarily added objects are prefixed with 
“TMP#_”, where “#” is a counter in CATIA V5, beginning with 1. Every AddTemp will 
increase the counter. This prefix is customizable by the customer. 

CMI RII→Insert/Replace To CATIA 

The menu item CMI RII→Insert/Replace To CATIA allows the user to load a CMI structure 
under a selected product or to replace the selected item in the structure. 

 

Insert: 

Read an assembly into CATIA V5 using the Read from Workbench command in CMI 
toolbar. 

Select a product to be the root of the inserted structure. 
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In CATIA V5 select the Insert from Teamcenter icon . 

 

Select the item revision of the BOM geometry or the dataset of the auxiliary 
geometry you want to use in CATIA V5 in the My Teamcenter application window. 
Click CMI RII→Insert/Replace To CATIA in the menu. 

 

CATIA comes to the foreground with the selected product and the used structure. 

Via Synchronize you can save the new Use-Relation in Teamcenter. 

 

 

Replace: 

Read an assembly into CATIA V5 using the Read from Workbench command in CMI 
toolbar. 

Select a product to be replaced in the structure. 

In CATIA V5 select the Replace from Teamcenter icon . 

 

Select the item revision of the BOM geometry or the dataset of the auxiliary 
geometry you want to use in CATIA V5 in the My Teamcenter application window. 
Click CMI RII→Insert/Replace To CATIA in the menu. 

 

CATIA comes to the foreground and asks if you want to replace all instances of the 
selected item or only the selected instance of the item. Then you see the changed 
structure. 

Via Synchronize you can save the changed structure in Teamcenter. 

CMI RII→Cancel CATIA Action 

The menu item CMI RII→Cancel To CATIA will cancel the CATIA action which is started 
from CATIA (e.g. SaveAs and AddTemp). 

CMI RII→Add 
CMI RII→Create 

 

The Newstuff settings for item and dataset (CMINewstuffItems, 
CMINewstuffItemsIndividualName, CMINewstuffDatasets, 
CMINewstuffDatasetsIndividualName) will be used for the newly created item/item 
revision and dataset. 

The item type selector in the create dialog can be switched on with the preference 
“CMISelectItemType” set to “1”. 

Set “CMICreateDialogRememberAttributes” to “1” in order to remember the 
attributes of the create dialog. 

CMI RII→Add→CATIA BOM Part Dataset 

The menu item CMI RII→Add→CATIA BOM Part Dataset will create a BOM part dataset 
for an existing item revision and relate it to the selected item revision. 

 

Select an item revision in the My Teamcenter application in Teamcenter. 

It is not possible to use this function if already a CATIA Product, BOM geometry or 
AUX geometry dataset exists for this item revision. An error message will occur. 

 

Select the menu item CMI RII→Add→CATIA BOM Part Dataset. 

The create dataset dialog will open (see Figure 39). Select a template dataset for a 
BOM part out of the possible values. Fill the values and click OK. 

The BOM part dataset will be created. The referenced CATIA file of the template 
dataset will be copied and saved with a new file name and added as named 
reference to the new dataset. The dataset will be related to the selected item 
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revision. 

 

Figure 39: Create dialog for CATIA BOM Part Dataset for Item Revision 

CMI RII→Add→CATIA AUX Part Dataset 

The menu item CMI RII→Add→CATIA AUX Part Dataset will create an auxiliary part 
dataset for an existing item revision and relate it to the selected item revision. 

 

Select an item revision in the My Teamcenter application in Teamcenter. 

It is not possible to use this function if already a CATIA BOM geometry dataset 
exists for this item revision. An error message will occur. 

 

Select the menu item CMI RII→Add→CATIA AUX Part Dataset. 

The create dataset dialog will open (see Figure 40). Select a template dataset for an 
auxiliary part out of the possible values. Fill the values and click OK. 

The auxiliary part dataset will be created. The referenced CATIA file of the template 
dataset will be copied and saved with a new file name and added as named 
reference to the new dataset. The dataset will be related to the selected item 
revision. 

 

Figure 40: Create dialog for CATIA AUX Part Dataset for Item Revision 
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CMI RII→Add→CATIA Product Dataset 

The menu item CMI RII→Add→CATIA Product Dataset will create a product dataset for 
an existing item revision and relate it to the selected item revision. 

 

Select an item revision in the My Teamcenter application in Teamcenter. 

It is not possible to use this function if already a CATIA Product or BOM geometry 
dataset exists for this item revision. An error message will occur. 

 

Select the menu item CMI RII→Add→CATIA Product Dataset. 

The create dataset dialog will open (see Figure 41). Select a template dataset for a 
product out of the possible values. Fill the values and click OK. 

The product dataset will be created. The referenced CATIA file of the template 
dataset will be copied and saved with a new file name and added as named 
reference to the new dataset. The dataset will be related to the selected item 
revision. 

 

Figure 41: Create dialog for CATIA Product Dataset for Item Revision 

CMI RII→Add→CATIA Drawing Dataset 

The menu item CMI RII→Add→CATIA Drawing Dataset will create a Drawing dataset for 
an existing item revision and relate it to the selected item revision. 

 

Select an item revision in the My Teamcenter application in Teamcenter. 

 

Select the menu item CMI RII→Add→CATIA Drawing Dataset. 

The create dataset dialog will open (see Figure 42). Select a template dataset for a 
drawing out of the possible values. Fill the values and click OK. 

The drawing dataset will be created. The referenced CATIA file of the template 
dataset will be copied and saved with a new file name and added as named 
reference to the new dataset. The dataset will be related to the selected item 
revision. 
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Figure 42: Create dialog for CATIA Drawing Dataset for Item Revision 

CMI RII→Create→CATIA BOM Part Item 

The menu item CMI RII→Create→CATIA BOM Part Item will create a new item with a 
BOM part dataset. 

 

Select the menu item CMI RII→Create→CATIA BOM Part Item. 

The create dialog for item and dataset will open (see Figure 43). Select a template 
dataset for a BOM part out of the possible values. Fill the values and click OK. 

The item, item revision, and BOM part dataset will be created. The referenced 
CATIA file of the template dataset will be copied and saved with a new file name and 
added as named reference to the new dataset. The dataset will be related to the 
new item revision. 
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Figure 43: Create dialog for CATIA BOM Part Item 

CMI RII→Create→CATIA AUX Part Dataset 

The menu item CMI RII→Create→CATIA AUX Part Dataset will create a new auxiliary 
part dataset. 

 

Select the menu item CMI RII→Create→CATIA AUX Part Dataset. 

The create dataset dialog will open (see Figure 44). Select a template dataset for an 
auxiliary part out of the possible values. Fill the values and click OK. 

The auxiliary part dataset will be created. The referenced CATIA file of the template 
dataset will be copied and saved with a new file name and added as named 
reference to the new dataset. 

 

Figure 44: Create dialog for CATIA AUX Part Dataset 
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CMI RII→Create→CATIA Product Item 

The menu item CMI RII→Create→CATIA Product Item will create a new item with a 
product dataset. 

 

Select the menu item CMI RII→Create→CATIA Product Item. 

The create dialog for item and dataset will open (see Figure 45). Select a template 
dataset for a product out of the possible values. Fill the values and click OK. 

The item, item revision, and product dataset will be created. The referenced CATIA 
file of the template dataset will be copied and saved with a new file name and added 
as named reference to the new dataset. The dataset will be related to the new item 
revision. 

 

Figure 45: Create dialog for CATIA Product Item 

CMI RII→Create→CATIA Drawing Dataset 

The menu item CMI RII→Create→CATIA Drawing Dataset will create a new drawing 
dataset. 

 

Select the menu item CMI RII→Create→CATIA Drawing Dataset. 

The create dataset dialog will open (see Figure 46). Select a template dataset for a 
drawing out of the possible values. Fill the values and click OK. 

The drawing dataset will be created. The referenced CATIA file of the template 
dataset will be copied and saved with a new file name and added as named 
reference to the new dataset. 
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Figure 46: Create dialog for CATIA Drawing Dataset 

CMI RII→Dataset Revise 

The menu item CMI RII→Dataset Revise revises the selected dataset. For more details 
see chapter Dataset pseudo Revise on page 107. 

 

Select the dataset you want to revise. Click CMI RII→Dataset Revise in the menu. 

About CMI RII 

This action opens a dialog which shows you the version of the installed CMI RII package. 
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Enhancement in the Active 
Workspace 
This section introduces the enhancement in the Active Workspace by listing its function. 

 

Send to CATIA 

Prerequisite: The Teamcenter Rich Client has to be started and the user has to be 
logged in. 

In the Active Workspace application the right wall command bar for item revision (see 
Figure 47: Active Workspace menu for item revisionFigure 47).contains the command 
Send to CATIA. It is possible to configure a Revision Rule and a Variant Rule in the dialog 
(see Figure 48). 

 

Figure 47: Active Workspace menu for item revision 
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Figure 48: Send to CATIA dialog in Active Workspace 

In the structure browser the command Send to CATIA is also available on the right wall 
command bar (see Figure 49). The context configuration for Revision Rule and Variant 

Rule will be used in the dialog (see Figure 50). 
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Figure 49: Active Workspace menu for structure 
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Figure 50: Send to CATIA dialog for structure in Active Workspace 
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CHAPTER 4 

CATIA relevant Objects in 
Teamcenter 
This chapter describes how to handle CATIA relevant data in Teamcenter. 

 

Predefined Object Structure 

The CATIA Teamcenter Interface (CMI RII) uses the following predefined object structure 
for CATProducts. 

 

Figure 51: Predefined CATProduct object structure 

An Item Revision has a Dataset attached of the type CMI2Product. The Dataset has 
exactly one Named Reference of the type CATProduct. This will be loaded to CATIA as a 
CATProduct. 

 
If no Dataset is attached to the Item Revision, a new Product is created in CATIA 
with the Read operation. 
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Figure 52: Predefined CATPart object structure 

An Item Revision has a Dataset attached of the type CMI2Part. The Dataset has exactly 
one Named Reference of the type CATPart. This will be loaded to CATIA as a CATPart. 

 
If an empty Dataset of the type CMI2Part is attached to the Item Revision, a new 
CATPart is created in CATIA with the Read operation. 

 

 

Named References of the type CMI2Part can handle references of the type model 
and cgr which will be loaded in CATIA with the Read operation. 

‘model’ is used for V4 CATIA model files. 

‘cgr’ is used for light geometry representation files. 

 

Working with Structures 

A structure is made of one or more items. 

An item can contain other items. 

Creating an Item 

 

In a Teamcenter Rich Client (e.g. My Teamcenter or Structure Manager application) 
select File→New→Item … 

 

The Item creation wizard is started and guides you through the Item Creation Process. 

Searching for Items 

 
In a Teamcenter Rich Client (e.g. My Teamcenter application) press the search  
button. 

 

In the Search window use the Predefined Search for Items. The result is displayed in the 
My Teamcenter application. 
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Creating a Structure 

To create or modify a structure in Teamcenter use the Structure Manager application. 

The figure below shows an example assembly with expanded items in the Structure 
Manager application browser. 

 

Figure 53: Example of an expanded assembly in Teamcenter Structure Manager 
application 

Example Structure for CMI 

The following instructions describe step by step how to create an example assembly 
structure which can then be loaded into the CATIA session: 

 

Start the Structure Manager application in Teamcenter Rich Client (see Figure 54). 

 

Figure 54: Empty Teamcenter Structure Manager application 
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Create a new item named “Table” with File→New→Item… 

 

Figure 55: Structure Manager application with “Table” 

 

Select the “Table” and create a new item named “Plate” with File→New→Item… 

Select the “Table” and create a new item named “Leg” with File→New→Item… 

 

Figure 56: Structure Manager application with “Table”, “Plate”, and “Leg” 

 

Select the “Plate”, and right click Send To→My Teamcenter. 
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Figure 57: My Teamcenter application with “Plate” 

 

Select the Item Revision “xxxxx/A;1 – Plate” and use the command  
File→New→Dataset… to create a new dataset of type CMI2Part to define a 
geometry. 
Use the More… button on the left side to select the type CMI2Part. 
The CMICatiaV5 Tool is set automatically. 

Press the OK button to continue. 

 

Figure 58: New Dataset dialog 

 

Repeat the same procedure for the “Leg” item and switch to the Structure Manager 
application. 

 

Select the “Leg” of the “Table” in the Structure Manager application and copy the 
item with Edit→Copy. 

Select the “Table” item and paste the “Leg” item three times with Edit→Paste. 
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Figure 59: Structure Manager application with complete “Table” 

 

Check that CATIA is started with installed CMI RII. 

 

Select the “Table” in the Structure Manager application and  
right click Send To→CMI RII. 

 

Select the “Table” in the CMI RII application and right click Expand Below. 

 

Figure 60: CMI RII application with complete “Table” 

 
Verify that all items are checked. Only checked and expanded items will be sent to 
CATIA. 

 

 

Use the Tools→Send To CATIA command to send the content to CATIA. 
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Figure 61: CATIA V5 with loaded “Table” 

Updating a Structure 

 

Complete construction in CATIA and press the Update button in CATIA V5. 

 

The files in CATIA and the metadata are updated to Teamcenter. 

 

Figure 62: CATIA V5 with updated “Table” 

 

Change the visible attributes in the CMI RII application and check the values for 
Occurrence name and Matrices. Both attributes are filled with the current CATIA 
data. 
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Figure 63: CMI RII application with complete “Table” 

 

Select the “Plate” and right click Send To→My Teamcenter. 
Verify that the dataset and a named reference are added. 

 

Figure 64: “Table” item in My Teamcenter 

Highlighting an Item in CATIA 

In cases where you have loaded an assembly structure to CATIA as described in the 
steps above, it may be useful to find the corresponding model in the CATIA session of an 
item displayed within the CMI RII application. 

For this purpose, it is possible to highlight CATIA models in CATIA using the currently 
selected item in the CMI RII application. 

 

In the CMI RII application, select the item you want to be highlighted in the CATIA 
session and choose the Highlight in CATIA option in the Pop-Up menu.  
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Figure 65: Highlight in CATIA in Pop-Up menu in CMI RII application 

 

CATIA comes to the foreground with the selected CATIA model highlighted. 

 

Figure 66: Highlighted item in CATIA V5 

 

The Highlight in CATIA action is also available in the Structure Manager, the Multi-
Structure Manager and the Manufacturing Process Planner application. 

Send to CATIA 

In the My Teamcenter application the context menu for item revision (see Figure 67) 
contains the commands Send to CATIA and Send Configured to CATIA. For details 
please see chapter CMI RII Menu bar in the My Teamcenter Application. 
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Figure 67: My Teamcenter context menu for item revision 
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CHAPTER 5 

Working with CATIA V5 

 

Introduction 

This chapter describes the CMI interface between CATIA V5 and Teamcenter. Typical 
tasks discussed are loading items/structures/drawings stored in Teamcenter into CATIA 
V5 and creating/updating parts and drawings in Teamcenter. One of the main 
subsections deals with creating and saving CATIA V4 models. 

 

Product Structure CATIA V5 vs. Teamcenter 

Product structures in Teamcenter correspond well to product structures found in CATIA 
V5. The following graphic illustrates the product structure in Teamcenter and CATIA V5. 

  

Figure 68: Product Structure in Teamcenter and CATIA V5 

 

CMI Toolbar 

The following figure shows the toolbar of the CATIA V5 CMI module. Descriptions of the 
toolbar and the command icons follow below. 
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Update Teamcenter

Synchronize Teamcenter

AddTemp from Teamcenter

CMI Info

Get original geometry from Teamcenter

Highlight in Teamcenter

Reconnect with Teamcenter

Save Session

Restore Session

Insert from Teamcenter

Read from Teamcenter

Manage Catalogs

Check In/Out in Teamcenter

Create/Attach an Archive

Replace from Teamcenter

Build Visualization

Browse in Teamcenter

Compare Version

 

Figure 69: CMI Toolbar in CATIA V5 

With the CMI toolbar it is possible to read files from the CMI RII application in Teamcenter. 
You can then modify the geometry in your CATIA V5 session. The modifications can be 
updated in Teamcenter via the Update Teamcenter or the Synchronize Teamcenter button 
in CATIA V5. 

The icon Highlight in Teamcenter is only active if you are working with a product structure. 

You can get the Teamcenter information of the CATParts, CATProducts, CATDrawings, 
and CATIA V4 Models with the CMI Info button if you loaded the product structure with 
CMI to CATIA V5. 

The other commands will be described in more detail later in this chapter. 

 

CATDrawings in CMI RII Application in Teamcenter 

CATIA V5 will read all expanded assemblies, single CATDrawings from the Teamcenter 
CMI RII application. 

The following figure shows a CATDrawing in the CMI RII application: 
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Figure 70: CMI RII application with a CATDrawing dataset 

When you have transferred a CATDrawing from Teamcenter to CATIA V5 via the CMI RII 
application, the drawing will be displayed in CATIA V5 in a new window. 

CMI for CATIA V5 also supports CATIA V4 models and CATIA V5 Drawing files 
(CATDrawings). CATDrawings may be included in assembly structures in Teamcenter, 
however in CATIA V5 they will be displayed in separate windows as shown in the figure 
below. 

All normal CMI functions (Read, Update, Create, and Save As) may be used with 
CATDrawings and CATParts within CATIA V5. 

 

Figure 71: Drawing Workbench for Read, Update,  
Create or Save As CATDrawing 
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CMI toolbar: Read From Workbench 

 

With the Read from Workbench button in the CMI Toolbar the content of the CMI RII 
application in Teamcenter may be read into CATIA V5. The CMI RII application may 
contain CATDrawings, and assembly structures. 

If you want to send one or more assemblies, CATParts, CATDrawings or cgms to CATIA 
V5 follow these instructions: 

 

Drag and drop or send drawings (CMI2Drawing datasets), cgms (CMI2Cgm 
datasets) or assemblies (items) into the CMI RII application. 

Expand or Deexpand the assemblies in the CMI RII application. Only those items 
that are shown in the CMI RII application will be opened in CATIA. 

 Read Teamcenter CATIA items with the Read From Workbench icon . 

Every top-level item in the CMI RII application will be opened in a separate browser 
in CATIA V5. 

 

If the Structure Manager application is the current active application in the 
Teamcenter Rich Client the Structure Manager content will be read to CATIA instead 
of the content of the CMI RII application. It is the same with the Multi-Structure 
Manager and the Manufacturing Process Planner application. 

 

CMI toolbar: Update Teamcenter 

 

This command updates geometry and position information in Teamcenter. 

 

Modify the content in CATIA. 

Write the modifications back with Update Teamcenter icon . 

 

All files in the assembly and the position information (transformation matrix) which 
have been modified in CATIA will be updated in Teamcenter. 

 

The success (green icon) and more detailed information (see Figure 72) are then 
displayed to the user. 
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Figure 72: Dialog Window for Update Teamcenter 

 

CMI toolbar: Synchronization in Teamcenter 

 

This command updates Teamcenter with any changes made to your CATIA V5 product 
structure. The changes that will be reflected in Teamcenter include: 

▪ any geometry and position information changes, 

▪ the creation of any new CATParts/cgrs/models and CATProducts that have been 
added to your product structure, 

▪ the creation of any new CATPart/cgr/model and CATProduct instances, 

▪ the removal of CATPart/cgr/model and CATProduct instances from the product 
structure. 

The changes made to the product structure since the last Read/Update/Synchronize are 
presented in the form of a list of operations to be performed in Teamcenter. 

 

Modify your product structure in CATIA by adding a new CATPart/cgr, adding a new 
CATProduct, removing a product or by changing the geometry of a CATPart. 

Write the modifications back to Teamcenter with the Synchronization in Teamcenter 

icon . 

 

The following dialog will appear, showing which changes need to be written to 
Teamcenter: 
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Figure 73: The Synchronize Teamcenter dialog 

The dialog's Operation column shows which procedures need to be performed in 
Teamcenter for each object and may be a combination of the following: 

Update The file and positional changes of any children will be updated in 
Teamcenter. 

Create The object will be created in Teamcenter. The object is completely 
new and not already in Teamcenter. 

Link Child At least one new parent-child relation will be created in Teamcenter. 
This reflects the addition of a child product in CATIA. 

Drop Child At least one parent-child relation will be deleted in Teamcenter. This 
reflects the deletion of a child product of the object in CATIA. 

 

The column Execute shows whether the operation will be executed or not. If there is any 
reason why the operation cannot be executed, then the reasons will be shown in the 
Result column. 

 

If new geometry files are to be created in Teamcenter the default is BOM Type. This 
will become an item and a dataset in Teamcenter. 

With the Edit PDM-Part category… button the category can be changed to No BOM 
Type in the Edit new PDM-Part category dialog (see Figure 74). This file will become 
a dataset in Teamcenter and will be attached to the parent item. 
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Figure 74: Edit new PDM-Part category dialog 

 

If the Synchronize button is pressed, the list of executable operations is worked 
through in the order shown on the screen. 

The results from Teamcenter are shown in the Output Window below the list. 

 

The Update operation: 

CATIA File objects will be updated in Teamcenter. No user interaction is necessary. 

 

The Create operation: 

CATIA File objects will be created in Teamcenter and the following steps will be 
completed: 

- A Teamcenter item will be created. 
The created item is also linked to the user’s Newstuff Folder (can be 
configured). 

- A dataset will be created under the item.  
The created dataset is also linked to the user’s Newstuff Folder (can be 
configured). 

- The file will be imported in the dataset as Named Reference with the correct 
type (CMI2Part, CMI2Product, etc.). 

For the interactive create in Teamcenter please see the remark below. 

 

The Link Child operation: 

- This may only appear as an operation for CATProduct objects, as CATParts 
cannot contain sub-products. In Teamcenter any new children will be added 
to the Teamcenter item of the parent object by creating a new BOM Line. 

 

The Drop Child operation: 

- This may only appear as an operation for CATProduct objects, as CATParts 
cannot contain sub-products. In Teamcenter any child CATProducts deleted 
from the CATIA product structure will be detached from the Teamcenter item 
of the parent object by removing the BOM Line. 

 

After every operation the success or failure will be registered in the result column of 
the dialog. If an operation fails the output window will provide you with the cause of 
the failure. 
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Figure 75: The Synchronization in Teamcenter dialog with success 

The Teamcenter item can be created interactively by filling the attributes in a dialog. This 
has to be switched on with the CMI RII preference CMICreateItemInteractive=1. The 
interactive create is possible for datasets, too (set the CMI RII preference 
CMICreateDatasetInteractive=1). 

 

Figure 76: The Create Item dialog 

It is possible to fill several forms for item and item revision in the create dialog. They are 
displayed in the sections “Item Form Information” and “Item Revision Form Information” in 
the dialog. 

The create of the forms has to be configured in the CMI RII preferences 
CMICreateItemItemFormList and CMICreateItemItemRevisionFormList. For details please 
refer to the CATIA Teamcenter Interface RII Customizing Manual. 
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Figure 77: The Create Item dialog with forms 

It can be configured to have the possibility to select the item type of the create item dialog 
from a set of possible item types. For this you have to set the CMI RII preference 
CMISelectItemType=1 and to define the types in the CMI RII preference 
CMICreateItemItemTypeList. 

 

Figure 78: Select the item type in the Create Item dialog 
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It is also possible to configure the create item and the create dataset dialog in that way 
that the values of the attributes – except the basic information attributes – will be stored 
and shown in the next dialog of the same type. You have to set the CMI RII preferences 
CMICreateItemDialogRememberAttributes=1 and 
CMICreateDatasetDialogRememberAttributes=1. 

 

Figure 79: Remember Attributes of the create dialog 

 

CMI toolbar: Highlight in Workbench 

 

If you want to highlight CATParts, CATProducts, and CATIA V4 models in the CMI RII 
application triggered by CATIA V5 perform the following steps. 

 

In CATIA V5 select the CATIA objects you want to highlight in the CMI RII 

application and choose the Highlight in Workbench icon  from the CATIA CMI 
toolbar. 

 

Now the items are selected in the CMI RII application. 

 
When the Structure Manager is active and the object is included in this window then it will 
be highlighted by the action above in CATIA V5. It is the same with the Multi-Structure 
Manager and the Manufacturing Process Planner application. 

 

CMI toolbar: Browse in Teamcenter 

 

This command allows to browse the Teamcenter object which is loaded in CATIA V5 in 
the Teamcenter client. 

 

In CATIA V5 select the CATIA objects you want to browse in the Teamcenter client  

and choose the Browse in Teamcenter icon  from the CATIA CMI toolbar. 

 

Now the items are opened in the My Teamcenter application. 

 

CMI toolbar: Creates/Attaches an Archive 

 

This command is described in the section Handling of CMIArchives on page 81. 
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CMI toolbar: Get original geometry from Teamcenter 

 

The Get original geometry from Teamcenter command retrieves geometry files (CATPart 
or CATIA V4 model) from Teamcenter if the geometry files are not yet loaded in CATIA 
V5. 

 

A CATProduct, CATPart or CATIA V4 Model has to be selected in the product 
structure. 

 

The function is used in context of huge product structures in CATIA to get the 
original geometry file from Teamcenter if the Do not activate default shapes on open 
option is set in the CATIA Product Visualization settings (see Figure 80). 

 

 

Figure 80: Do not activate default shapes on open option in CATIA V5 

 

CMI toolbar: Insert from Teamcenter 

 

The Insert from Teamcenter command allows the user to load a CMI structure under a 
selected product. 

 

Read an assembly into CATIA V5 using the Read from Workbench command in CMI 
toolbar. 

Select a product to be the root of the inserted structure. 

In CATIA V5 select the Insert from Teamcenter icon . 
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Drop the assembly structure you want to use in CATIA V5 in the CMI RII application 
window. Expand it as necessary. Click Tools→Insert/Replace To CATIA in the menu 

or press the Insert/Replace To CATIA icon  in the CMI RII toolbar in Teamcenter. 
Changes or expands you make to other assembly structures in the Workbench will 
not be sent to CATIA. 

Alternatively you can drop the item into the Structure Manager, the Multi-Structure 
Manager or the Manufacturing Process Planner. There is only one root item. Expand 
it as necessary. Click CMI RII→Insert/Replace To CATIA in the menu. 

Or you can select the item revision in the My Teamcenter application and click CMI 
RII→Insert/Replace To CATIA in the menu. 

 

CATIA comes to the foreground with the selected product and the used structure. 

The dropped part/structure is removed from the CMI RII application window after you 
sent it to CATIA. 

Via Synchronize you can save the new Use-Relation in Teamcenter. 

 

CMI toolbar: Replace from Teamcenter 

 

The Replace from Teamcenter command allows the user to replace the selected item in 
the structure. 

 

Read an assembly into CATIA V5 using the Read from Workbench command in CMI 
toolbar. 

Select a product to be replaced in the structure. 

In CATIA V5 select the Replace from Teamcenter icon . 

 

Drop the assembly structure you want to use in CATIA V5 in the CMI RII application 
window. Expand it as necessary. Click Tools→Insert/Replace To CATIA in the menu 

or press the Insert/Replace To CATIA icon  in the CMI RII toolbar in Teamcenter. 
Changes or expands you make to other assembly structures in the Workbench will 
not be sent to CATIA. 

Alternatively you can drop the item into the Structure Manager, the Multi-Structure 
Manager or the Manufacturing Process Planner. There is only one root item. Expand 
it as necessary. Click CMI RII→Insert/Replace To CATIA in the menu. 

Or you can select the item revision in the My Teamcenter application and click CMI 
RII→Insert/Replace To CATIA in the menu. 

 

CATIA comes to the foreground and asks if you want to replace all instances of the 
selected item or only the selected instance of the item. Then you see the changed 
structure. 

The dropped part/structure is removed from the CMI RII application window after you 
sent it to CATIA. 

Via Synchronize you can save the changed structure in Teamcenter. 

 

CMI toolbar: Add Temp 
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The AddTemp command allows the user to visualize a temporary structure together with 
the working one. 

For example, if the user is making a design of a car and wants to see if the luggage boot 
is big enough, he can load a suitcase as a temporary structure by doing the following 
(supposing that the car structure is already loaded): 

 

In CATIA V5, go to Tools→Options→Compatibility (Tab: “CMI”) and make sure that 
the option “Use one temporary product window…” is checked. 

 

Read an assembly (here the car assembly) into CATIA using the Read command in 
CMI toolbar. 

In CATIA V5 select the AddTemp from Teamcenter icon 

 

. 

 

Drop the assembly or model you want to add temporarily to CATIA (the suitcase) 
into the CMI RII application. Expand it as necessary. Click Tools→Temp To CATIA 

in the menu or press the Temp to CATIA icon  in the CMI RII toolbar in 
Teamcenter. Changes or expands you make to other assembly structures in the CMI 
RII application will not be sent to CATIA. 

Alternatively you can drop the item into the Structure Manager, the Multi-Structure 
Manager or the Manufacturing Process Planner. There is only one root item. Expand 
it as necessary. Click CMI RII→Temp To CATIA in the menu. 

Or you can select the item revision in the My Teamcenter application and click CMI 
RII→Temp To CATIA in the menu. 

 

CATIA comes to the foreground with both the original and temporarily added 
structures loaded in the same window – here the car and the suitcase structure. 

It will not be possible to make any changes to the temporarily added (suitcase) 
structure. 

The temporarily added part/structure is removed from the CMI RII application after 
you sent it to CATIA. 

 

All Part Numbers and File Names in the temporarily added structure are prefixed 
with “TMP#_”, where “#” is a counter in CATIA V5, beginning with 1. Every 
AddTemp will increase the counter. This prefix is customizable by the customer. 

 

Limitation: 
CATProducts are not transferred to CATIA, the products will be represented by 
“CATIA Components”. Only position information from Teamcenter is processed. 

Visualize multiple revisions of an Assembly using Add Temp 

Add Temp in CATIA V5 can be used to load different versions (revisions) of an assembly 
or model at the same time. In order to make this possible, the Part Numbers and File 
Names of the temporarily added assembly are prefixed with “TMP#_”. 

 

In CATIA V5, go to Tools→Options→Compatibility (Tab: “CMI”) and make sure that 
the option “Use one temporary product window…” is checked. 

 

Read revision B of your assembly as described in CMI toolbar: Read From 
Workbench. 

You will find that it is opened in CATIA underneath a product tagged “CMI 
Workbench”. 

 In CATIA V5 select the Add Temp from Teamcenter icon . 

 

Find and expand Revision A of your assembly (drop it in the CMI RII application 
window and use the Expand Below command in Teamcenter). Click Tools→Temp 
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To CATIA in the menu or press the Temp to CATIA icon  in the CMI RII toolbar in 
Teamcenter. Changes or expands you make to other assembly structures in the 
Workbench will not be sent to CATIA. 

Alternatively you can drop the item into the Structure Manager, the Multi-Structure 
Manager or the Manufacturing Process Planner. There is only one root item. Expand 
it as necessary. Click CMI RII→Temp To CATIA in the menu. 

Or you can select the item revision in the My Teamcenter application and click CMI 
RII→Temp To CATIA in the menu. 

 

Revision A and B of your assembly are opened in the same Window in CATIA V5. 
You can overlay and position the assemblies relative to each other for comparison. 

 

CMI toolbar: Compare Version 

 

Similarly to Add Temp, Compare Version is used to load different versions of the same 
assembly. However in this case, the version that is already open is read only and the 
version that is added can be modified. 

 

In CATIA V5, go to Tools→Options→Compatibility (Tab: “CMI”) and make sure that 
the option “Use one temporary product window…” is checked. 

 

Read revision A of your assembly as described in CMI toolbar: Read From 
Workbench. 

You will find that it is opened in CATIA underneath a product tagged “CMI 
Workbench”. 

 In CATIA V5 select the Compare Version icon . 

Notice that Revision A is renamed with the “TMP#_” prefix. Revision A can no longer 
be modified and saved in Teamcenter. 

 

Find and expand Revision B of your assembly. Use Send To CATIA. 

 

 

Revision A and B of your assembly are opened in the same Window in CATIA V5. 
You can overlay and position the assemblies relative to each other for comparison. 

 

Use Synchronize Teamcenter to update Revision B of the assembly. Notice that 
Revision A and all it referenced files are ignored and will not be modified in 
Teamcenter. 

 

CMI toolbar: Build Visualization 

 

The Build Visualization command builds up or updates a visualization file from a selected 
product and stores the visualization under the selected item. These cgr can then be 
created/updated with the CMI Synchronize command. 

The Visualization files are only sent to CATIA if the preference Send visualization files to 
CATIA? is checked, or if the Expand for Visualization command in the context menu of the 
CMI RII application is used for expand. 

CMI RII does not control the content or actuality of the visualization file. 
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CMI toolbar: Reconnect with Teamcenter 

 

CMI recognizes files that have been loaded into CATIA V5 through the CMI RII application 
window. Since it knows that they are from Teamcenter, it can update them there. 

Other files, which you load with e g. File→Open, it will not know. They will be regarded by 
Synchronize as new files, and it will create new Teamcenter objects for them. 

If you open a product structure from disk that contains files that are already in 
Teamcenter, you can use Reconnect with Teamcenter to make CMI RII recognize these 
files. It will recognize products if the part number is correct, and CATPart/model files 
based upon their filename. If the CATPart is a BOM CATPart (Component) in Teamcenter, 
the part number must also match. 

 

Figure 81: Reconnect dialog 

These are the possible Synchronize Status: 

CMI-Unknown CMI does not know this item at all. It would be created as a new 
part in Teamcenter. 

Can be reused CMI knows this item is in Teamcenter. But it appears that in 
Teamcenter there is no instance known by the same instance 
name under the same parent item. Maybe it was deleted or is 
new. Synchronize would create a new instance of the existing 
Part in Teamcenter. 

Can be updated CMI knows the object as well as this instance is in Teamcenter. It 
can be updated in Teamcenter. 

Can not be 
updated 

CMI knows the object as well as this instance is in Teamcenter, 
but it is not writeable and cannot be updated in Teamcenter. 

Archive content The object is part of a CMIArchive. 

Broken Link A broken link cannot be reconnected. It will be ignored during 
synchronize. 

 

An asterisk (*) in the Synchronize Status column signifies that the Reconnect Dialog 
recognized the item, but it is not yet reconnected. Items are actually reconnected when 
you close the dialog with OK. 

Click Cancel to keep them as unknown, e.g. if you want to save them as new Teamcenter 
objects. 

 
Reconnect does not create anything in Teamcenter or updates any files.  
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Please use Synchronize to update the data. 

 

 

Load a CATProduct into CATIA V5 using File→Open. 

In CATIA V5 select the Reconnect with Teamcenter icon . 

 

In the CMI Reconnect Dialog, click Select unknown. In this case, all lines will be 
selected. Click Reconnect selected. If any items are recognized in Teamcenter, they 
will change their status. To reconnect these items, close the dialog with OK. Click 
Cancel to leave the dialog without reconnecting the items. 

 

Reconnected items that are writeable in Teamcenter will be in the “modified” state, 
to be able to update them in Teamcenter. 

Use Synchronize to create the unknown/new data and to update the reconnected 
files. 

 

 
If you want to keep individual items as new, unselect them before you click 
Reconnect selected. 

 

Use mapping file 
If a mapping file was created when the product structure was first imported into 
Teamcenter, this file can be used to map the CATIA names to the names the products 
have in Teamcenter. Click the Use mapping file button to retrieve a mapping file that is 
attached to the top level Item from Teamcenter and map between external names and 
Teamcenter names. 

Import/Export using mapping files needs to be enabled by your CMI administrator. See 
Optional CMI Functionality on page 111. 

Reconnect CMIArchives 
By default, Reconnect does not search Teamcenter for CMIArchives to reconnect a 
CATProduct. Check Reconnect CMIArchives to also search for CMIArchives. Keep in 
mind, however, that several different Archives can contain a root product with the same 
part number or file name. If this is the case, you will be asked to select one of these. 

Synchronize Configuration 
Here you can control for individual files how they should be treated during Synchronize, as 
well as how they are going to be reconnected. 

Update/New 
In order to be updateable, a file has to be connected with Teamcenter. If the file is 
connected, but you rather want to store it as a new file, click New to disconnect the file, so 
that it will be created as a new object in Teamcenter during Synchronize. The same allows 
to copy a part or data item that you have originally opened from Teamcenter. 

Ignore 
Ignore this item in Synchronize (neither create a new item nor update). 

Part number, Instance name, File name 
If the file is archived in Teamcenter under a different name than it has in CATIA, you can 
suggest the name here. It will take the place of the name in CATIA when Teamcenter is 
searched for the item. 

 

CMI toolbar: Manage Catalogs 

 

This command is described in the section Handling of catalogs on page 74. 



 

CMI RII Release 4.9 - User Manual  67 

 

CMI toolbar: Local Save and Restore 

 

Using Save Local the content of the CATIA V5 session can be stored locally. 

This snapshot of the session will persist even when CATIA V5 is closed. 

 

 

When the session is restored with Restore Local, you can continue your work as if you 
had just used Read from Teamcenter, i.e. you can perform Updates. 

The Restore Local command is only available when the CATIA is empty – i.e. no 
documents are open – to avoid conflicts. 

 

With Save/Restore Local you can avoid reading large assemblies from Teamcenter 
repeatedly. However, the status of the data in Teamcenter may change if you keep 
your local snapshot for a long time. It may get “stale”. 

 

The following restrictions apply: 

▪ Only one saved session is maintained at a time. 

▪ The session can only be saved when the data is up to date. I.e. there are no files in a 
modified state, and no new files. 

▪ The Save/Restore Local does not restore files that were not loaded from the PDM 
system. 

 

CMI toolbar: CMI Info 

 

This command displays the information from Teamcenter for CATParts, CGRs, 
CATProducts, CATDrawings, cgms, and CATIA V4 Models. 

The More … button displays attributes of the correspondent Teamcenter objects. The 
range of attributes can be customized. 
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Figure 82: Information dialog window for CATProduct with “More Attributes” 

 

Select the CATPart, CATProduct, CATDrawing, cgm or CATIA V4 Model. 

In CATIA V5 select the CMI Info icon . The appropriate dialog info window 
appears. 

 

 

You can also select multiple CATIA items. Information will be displayed in a table 
view. 

Then you can select a line and switch to the "Single Object" tab. There the attributes 
are shown. 



 

CMI RII Release 4.9 - User Manual  69 

 

Figure 83: CMI Information for multiple items 

 

CMI toolbar: Check In/Check Out 

 

This function is used to check in and check out datasets from the CATIA V5. 

 

Figure 84: Check In/Check Out dialog 

The dialog shows the following: 

▪ Info 
Shows the modification state in CATIA as icon. 

▪ CATIA State 
Shows the modification state in CATIA. 

▪ TC-State 
Shows the check in/check out, revise state of the dataset in Teamcenter. 

▪ Name 
Shows the name of the object. 

▪ Result 
Shows the result for the last action for the file. 
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Additional columns can be configured in CATIA and the values for these attributes will be 
sent from Teamcenter. Details please see in the CATIA Teamcenter Interface RII 
Customizing Manual. In Figure 84 the columns “Checked-Out By”, “Object String Dataset”, 
and “Object String Item Revision” are configured. 

The following actions are possible: 

▪ Refresh from TC 
Refresh the information from Teamcenter. 

▪ Check In/Check Out 
Before performing the Check In/Check Out action, the user has to select the files 
to be checked in/checked out. 

▪ Revise (see Dataset pseudo Revise on page107) 
Before performing the Revise action, the user has to select the files to be revised. 

 

Handling of CATDrawings 

CATDrawings can be included in your assembly structures in Teamcenter. All the usual 
functions (Read, Update, Create and Save As) are supported for CATDrawings in CATIA 
V5 via the CMI toolbar. 

CATDrawings may be created for single models or for assemblies. There are however 
several caveats when working with CATDrawings and CMI, depending on the context of 
the CATDrawing. 

Creating a CATDrawing from a Single Model 

When creating a CATDrawing for a CATPart, send the CATPart item from Teamcenter to 
CATIA V5, and then create the CATDrawing. This method will preserve the context of the 
CATDrawing - irrespective of whether the CATPart is later loaded into CATIA singly or as 
part of an assembly. If you later make changes to the CATPart, and you wish the 
CATDrawing to update and reflect the changes, you must load both the CATPart and the 
CATDrawing in CATIA V5 using CMI before you update the CATDrawing. 

 

Drag and drop the CATPart item on the CMI RII application or use 
Send To→CMI RII with the CATPart Item. 

Select Tools→Send To CATIA or use the Send To CATIA icon  in the CMI RII 
toolbar in Teamcenter. 

 

Create the CATDrawing with the usual CATIA V5 functions. 

Select the Synchronize in Teamcenter icon . 

Creating a CATDrawing from a Product Structure 

 

Drag and drop the assembly into the CMI RII application. 

Select Tools→Send To CATIA or use the Send To CATIA icon  in the CMI RII 
toolbar in Teamcenter. 

 

Create the CATDrawing with the usual CATIA V5 functions. 

Select the Synchronize in Teamcenter icon . 
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Derived files for CATDrawing 

In the Teamcenter preference CMIDrawingFileFormatsList you can define the formats of 
the files that should be derived from the CATDrawing when it is created or updated in 
Teamcenter. Possible values are “pdf” and “tif”. 
The dataset names for CATDrawing, pdf, and tif are the same. 
For the pdf format, there will be one file including one page for each sheet. 
For the tif format, there will be one file for each sheet. The sheet name will be stored in 
the description of the dataset. 
When the CATDrawing dataset is related to an item revision then the datasets for pdf and 
tif are related to this item revision, too. The names of the datasets are derived from the 
part number and revision of the item revision. 
When the CATDrawing dataset is not related to an item revision then the datasets for pdf 
and tif are created without relation. The names of the datasets are derived from the file 
name in CATIA (without revision). 
There exists no relation between the datasets for CATDrawing, pdf, and tif. 
The standard Teamcenter datasets for pdf (“PDF”) and tif (“TIF” for TC 8.3 and above; 
“Image” for TC 2007.2) will be used. 

Automatic Update of CATDrawing title block parameter 

 
CMI RII can automatically update text fields in the drawing title blocks with attributes 
from Teamcenter. This requires a configuration in Teamcenter. 

 

 

Use Edit→Options to open the Teamcenter preferences dialog. 

Switch to the index tab and check the following preferences: 
- CMIDrawingParameterAttributesTC 

- CMIDrawingParameterAttributesCATIA 

(see Figure 85). 

 

 

Figure 85: Options Dialog in Teamcenter 

 

CMIDrawingParameterAttributesTC defines a list of Teamcenter attribute 

names of the dataset object in Teamcenter. 

Example: 

object_desc 
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object_name 

CMIDrawingParameterAttributesCATIA defines the parameter names in 

CATIA. 

Example: 

PdmDescription 
PdmName 

These two lists must have the same length. 

 

 

In CATIA the Knowledgeware Parameters can be defined in the CATDrawing object. 

With the Attribute Link command in CATIA these parameters can be connected to 
text fields in the CATDrawing. 

 

CMI RII will update the Knowledgeware Parameters in the CATDrawing document. 

With the example values above the object_desc attribute of the CMI2Drawing dataset 

is read in Teamcenter and set in the PdmDescription parameter in CATIA (see Figure 86) 
and the object_name attribute of the CMI2Drawing dataset is read in Teamcenter and 

set in the PdmName parameter in CATIA. 

 

Figure 86: CATDrawing Parameter in CATIA V5 

With the CMIRead command the parameters are updated in the CATDrawing document in 
CATIA. 

 

Handling of cgm files 

CATIA V5 cgm files are managed like the CATDrawings in CMI RII. 

A newly created or opened cgm file can be created in Teamcenter with the Synchronize of 
CMI RII. There will be created a dataset with the named reference of the cgm file. The 
relation to an item revision has to be created manually because there is no reference to an 
item. 

The usual functions (Read, Update, and Save As) are supported for cgm files in CATIA V5 
via the CMI toolbar. 
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When cgm files are included in your product structure in Teamcenter and this structure is 
read in CATIA, the cgm file will be opened in a separate window. It can be configured in 
the CMI RII options (see Figure 7) not to send the cgm file to CATIA. 

 

Handling of cgr and model files 

CATIA V5 cgr files and CATIA V4 Model files are managed as representation of an 
embedded component in the product structure. It is not possible to modify such a 
representation directly. It is only possible to use the Save As function of CATIA V5 to 
create a new cgr or model file of a loaded CATPart or CATProduct. To update the 
representation you have to replace the original representation by the new representation. 

 

Load an assembly which uses a cgr or model in the product structure. And use the 
right click Representations→Manage Representations … command (see Figure 87). 

 

Figure 87: Manage Representation dialog of CATIA V5 

 

Use the “Replace” function to use the cgr or model file with a new representation. 
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Figure 88: Manage Representation dialog of CATIA V5 with new model file 

 

Use the CMI Update or Synchronize functionality to update the new cgr or model file 
in Teamcenter. 

 

During the CMI Update or Synchronize process CMI replaces the original 
representation file in the exchange directory by the new representation file and 
changes the “Source” path of the representation back to its original value. Then the 
new representation file (which has the name of the old file) is updated in 
Teamcenter. 

To use this function you need write access to the cgr or model data item in 
Teamcenter. Although the cgr or model is represented in an embedded component 
of a higher CATProduct you need no write access to the CATProduct. 

 

 

Restrictions: 
- There must be only one representation in one component. 
- The “Name” of the representation must not change. 

 

Handling of catalogs 

CMI can also manage catalog files in Teamcenter. Teamcenter compatible catalogs 
reference files and items that are actually stored in Teamcenter. If the user opens or 
inserts a file from the catalog, CMI retrieves the corresponding data from Teamcenter and 
starts the defined catalog function (see section Update or Create Catalog for function 
details) with the retrieved file(s). 

Manage Catalogs 

 

 
The Manage Catalogs icon is enabled when you have a CATProduct active. It allows 
retrieving catalogs from Teamcenter for browsing. 

 

 

After starting the Manage Catalogs command the Select Catalog for browsing dialog 
will be opened in CATIA. 
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Figure 89: Select Catalog for browsing dialog 

 

Pick from the list of catalogs available in Teamcenter and select the Open Catalog 
for Browsing button. The catalog will be opened in a CATIA Catalog browser. 

 

 

Figure 90: Bolt Catalog opened in CATIA V5 

 

Double click an end chapter to open the item from Teamcenter. CMI RII will load the 
required files from Teamcenter if needed. 

 

 
You cannot use Open Document or Open As New Document in this context. 
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Read Catalog 

 

 

The administrator needs to set CMI_ENABLE_CMICATALOGREADCMD=ON in the 

CATIA environment in order to enable the Read Catalog function. 

The Read Catalog icon is enabled when you have a CATProduct active. It allows 
you to retrieve catalogs from Teamcenter for editing. 

 

 

After starting the Read Catalog command the Select Catalog for editing dialog will 
be opened in CATIA. Read Catalog allows to retrieve CATCatalogs from 
Teamcenter for editing. 

 

 
Only catalogs with write access in Teamcenter will be retrieved from Teamcenter. 

 

  

Figure 91: Select Catalog for editing dialog 

 

Pick from the list of catalogs available in Teamcenter and select the Open Catalog 
for Editing button. The catalog document will be opened in a CATIA catalog editor. 
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Figure 92: Edit catalog in CATIA V5 

 

Use the Select document in session button to build the catalog from parts or files 
that were opened from Teamcenter via CMI. 

Insert CATScript into Catalog 

 

 

The administrator needs to set CMI_ENABLE_CMICATALOGINSERTSCRIPTCMD=ON 

in the CATIA environment in order to enable the Insert CATScript from Teamcenter 
into Catalog function. 

The Insert CATScript from Teamcenter into Catalog icon is enabled when you have 
opened a catalog for editing. 

 

 

Use Read Catalog to retrieve a catalog from Teamcenter for editing. Select an end 
chapter. Click the Insert CATScript from Teamcenter into Catalog icon. The query 
dialog for script datasets will be opened (see Figure 93). 

 

 
Only script datasets with a filled named reference will be queried in Teamcenter. 
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Figure 93: Query script dataset dialog 

 

Fill the query criteria in the dialog. Owning User and Owning Group are filled with the 
current values of the session user. Select the “OK” button. The query result window 
opens. You have to select the dataset and click the “OK” button. With a click on the 
“New Query” button you can start a new query for script datasets. 

 

Figure 94: Query result dialog for script datasets 

 

The script will be inserted into the catalog. 

 

Figure 95: Catalog with inserted script 
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Update or Create Catalog 

 

 

The administrator needs to set CMI_ENABLE_CMICATALOGUPDCRECMD=ON in the 

CATIA environment in order to enable the Update or Create Catalog function. The 
Update or Create Catalog icon is enabled when you have a catalog active. 

 

 

Update or Create Catalog allows saving new or updated catalogs in Teamcenter. It 
will manage the necessary keyword attributes so that the items contained in the 
catalog can be retrieved from the Teamcenter database instead of the local file 
system. 

 

After starting the Update or Create Catalog command the catalog document is 
analyzed and the following dialog is shown. 

 

Figure 96: Synchronize Catalog dialog 

 

For new catalogs that were not already opened from Teamcenter, the user can 
change the file name which should be used in Teamcenter. 

 
  

 

The type can be Open, Open as copy, and Instantiate. These types describe the 
way in which the items will be handled when the catalog is used with the Manage 
Catalogs command. 
 

Open Open the referenced object in CATIA so that the 
existing Teamcenter item is used (e.g. standard part). 

Open as copy Open the referenced object in CATIA so that it will be 
recognized as a new item in Teamcenter (e.g. 
templates). 

Instantiate Instantiate is used for Features and Power copies which 
will be instantiated in the active document. 

 
The Status Field can be Loaded by CMI, Updated by CMI, Not known by CMI, 
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and Created by CMI. 
 

Loaded by CMI The item is from Teamcenter and already was in the 
catalog at load time. 

Updated by CMI The item is from Teamcenter but the type was changed. 

Not Known by CMI The item is not from Teamcenter. 

Created by CMI The referenced file was opened from Teamcenter and 
is new in the catalog. 

 

 

 After pressing the Synchronize icon  CMI will check all entries and if there are 
unknown entries, the user must confirm, that he wants to continue. 

 

Figure 97: Confirmation dialog for unknown entries in the synchronize catalog 
command 

 
This indicates that there is an item referenced in the catalog that is not managed by 
Teamcenter. 

 

 

Next the catalog is registered or updated in Teamcenter. 
Figure 98 is shown when the Synchronize command ends successfully. 

 

 

Figure 98: Synchronize Catalog with success 
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Handling of CMIArchives 

CMI supports the use of CMIArchives. A CMIArchive is a dataset in Teamcenter which 
contains a CATIA V5 structure. The structure has one root item which can be a 
CATProduct or a CATPart. If the root item is a CATProduct, it can contain more items of 
type CATIA V5 Component, CATIA V5 CATProduct or CATIA V5 CATPart. 

In the following sections the handling of CMIArchives is described in detail. 

Creates/Attaches an Archive 

 

 

First open the CMI RII application in Teamcenter and open an item in the CMI RII 
application (see Figure 99). After sending the CMI RII application content to CATIA 
V5 (Tools→Send To CATIA in Teamcenter or the Read Command in CATIA V5), the 
product structure is loaded in the CATIA V5 application. 

 

Figure 99: Item 000160 in the CMI RII application window 
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Figure 100: Loaded item 000160 in CATIA V5 

Figure 100 shows the loaded product in CATIA V5. Now we add the structure which 
should be attached as CMIArchive as child items to the item 000160. In our example the 
three possible types are added under the root item (see Figure 101). 

 

Figure 101: CMIArchive root product with three children 
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Select the root product which should be attached as CMIArchive (see “ArchiveRoot 
(ArchiveRoot.1)” in Figure 101). The parent object of the selected item must be 
loaded from CMI. The CMIArchive will be attached to an existing CMI structure by 
using the Attach Archive CMI toolbar button. 

In CATIA V5 select the Attach Archive icon . 

 

 

In the Teamcenter client the create dialog for the new dataset (see Figure 102) will 
appear. 

 

Figure 102: Create CMIArchive Dataset dialog 

 

After creating all objects and relations in Teamcenter the user will be asked to 
update the parent product in Teamcenter (see Figure 103). 

 

Figure 103: Update parent product message box 

 

After the update the user gets the information from Teamcenter in a message 
window within CATIA V5 (see Figure 104). 
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Figure 104: CMI Messages window 

 

CMI RII has created a new CMI2Archive dataset in Teamcenter. The dataset is 
linked with the item 000160. Figure 105 shows the expanded CMI2Archive dataset 
in the My Teamcenter application. 

 

Figure 105: CMIArchive item in Teamcenter 

 

In CATIA V5 the Teamcenter data is attached for the CMIArchive. The CMI info 
dialog (see Figure 106) shows the information for the CMIArchive object in CATIA 
V5. 
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Figure 106: CMIArchive Information 

 

The CMIArchive can be modified or extended, e.g. by adding new CATParts, 
CATProducts, etc. A changed CMIArchive can be updated in Teamcenter with the 
standard CMI Update commands. 

Modify non CATIA archive content 

 

It is possible to add some non CATIA files to the CMIArchive. By default these files have 
to be located in the CMI exchange directory. 

 
To enable this function the administrator has to set the CATIA V5 environment 
CMI_REMOVE_CMIMODNCARCCMD=OFF. 

 

 

It is possible to select a special directory from where you can select non CATIA 
files. Therefore use the CATIA→Tools→Options functionality. 
In General→Compatibility→CMI please select “Use extra directory for non CATIA 
items in CMI-Archive” and set a directory. 
Note: You have to restart CATIA after changing this setting. 

 

 

To manage a non CATIA file in the archive you have to select any member of the 

archive and press the Modify non CATIA archive content icon . You will get the 
dialog shown in Figure 107. 
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Figure 107: Modify non CATIA CMIArchive content 

 

 

To add some files press the Add non CATIA files button of the dialog. A second 
dialog appears. This dialog shows all files of the CMI exchange directory except the 
loaded CMI product structure files and other CATIA files. To show non CMI CATIA 
files you can deselect the filter checkbox. 

Select the files you want to add to the CMIArchive and press OK. The selected files 
are added to the CMIArchive. During CMI Update the files are packed to the 
CMIArchive file. During read the files are extracted from the CMIArchive. 

 

It is also possible to select a file in the dialog and to remove it from the CMIArchive 
by pressing Remove non CATIA files. During CMI Update the files are removed from 
the CMIArchive file. 

Support for BOM Parts under CMIArchive 

It is possible to use Items from Teamcenter within an Archive.  

 
To enable this function the administrator has to set the CATIA V5 environment 
CMI_ARCHIVE_BOM_CHILDREN=ON. 

 

BOM Parts (Items loaded from Teamcenter) can only be inserted into already existing 
Archives. 

 

Load an existing Assembly from Teamcenter. 

Insert the Root product of the product structure you want to become a CMIArchive. 

Use Creates/Attaches an Archive to create the CMIArchive. 

Load an Item from Teamcenter and insert it into a product that is part of the 
CMIArchive (see section Creates/Attaches an Archive); or use the Insert from 
Teamcenter (see section CMI toolbar: Insert from Teamcenter) command. 

In Figure 108 you can see the inserted Item "000649" in the CMIArchive. 
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Figure 108: BOM part in CMIArchive 

An CMIArchive with BOM Parts can only be updated with the Synchronize Teamcenter 
command (see Figure 109).  

 

Figure 109: Synchronize Teamcenter of CMIArchive 

CMI RII will create a relation between the BOM Part and the Assembly that attaches the 
CMIArchive (see Figure 110). 

For that reason you can only attach BOM Parts if the CMIArchive was loaded together 
with its Teamcenter Assembly. 



 

88 CMI RII Release 4.9 - User Manual  

 

Figure 110: Created relation for the BOM Part 

The transformation (positioning information) stored in Teamcenter for this part instance is 
a summary of the transformations that are hidden in the CMIArchive; so the positioning 
e.g. in a DMU is correct relative to the assembly. 

 
Since in CATIA it may not be obvious which parts of the product structure are stored 
in the CMIArchive and which are individual parts in Teamcenter, the ability to use a 
BOM Part under a CMIArchive should only be used for specific use cases, where 
this is implicitly clear to the user. 

One use, for instance, is to build supplier Parts into an OEM structure, where 
differentiation may be possible by the different naming conventions. 

 

Handling of CATAnalysis 

Analysis stored in a CATAnalysis dataset 

CATAnalysis files can be stored in Teamcenter as a dataset. The analysis is attached to 
the Teamcenter Item Revision of the CATProduct or CATPart that it is referencing. It is 
handled in a similar way as a CATDrawing - normally the CATAnalysis files are not 
loaded; it is loaded if it is explicitly expanded in the CMI RII application or switched on in 
the options (see section Menu item Edit). 

Unlike with a CATDrawing, the assemblies referenced by the CATAnalysis are updated if 
you use the Synchronize Teamcenter function in the Analysis Workshop. 

 
To manage CATAnalysis as a native file, your administrator has to set the CATIA V5 
environment CMI_STORE_ANALYSIS=ON. 

 

 

Load an Assembly or Part from Teamcenter. 

In CATIA, generate the CATAnalysis (see Figure 111). 



 

CMI RII Release 4.9 - User Manual  89 

 

Figure 111: CATAnalysis 

Use Synchronize Teamcenter to store the CATAnalysis file in Teamcenter. Synchronize 
will also update the Assembly the CATAnalysis is referencing (see Figure 112). 

 

Figure 112: Synchronize Teamcenter of CATAnalysis 

 

In Teamcenter the dataset for the CATAnalysis will be created and attached to the 
Part or Assembly for which the CATAnalysis was generated (see Figure 113). 
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Figure 113: Existing item in Teamcenter 

 

To read the CATAnalysis drop the Item into the CMI RII application. 

Set the option Send analysis files to CATIA? in the CMI RII preferences or expand 
the Analysis with the context action Expand Analysis and send the Item to CATIA 
(see Figure 114). 

 

Figure 114: Expand Analysis in CMI RII application 

Analysis stored in a CMIArchive dataset 

The CATIA V5 data type CATAnalysis can be stored in a CMIArchive (see Handling of 
CMIArchives). 

 

Read an existing product structure document (see Figure 115) to CATIA V5 (see 
Figure 116). 
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Figure 115: Existing item in Teamcenter 

 

Figure 116: Item loaded by CMI 

 

Attach an existing CATAnalysis file with the CATIA V5 functionality Add existing 
component (see Figure 117). 
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Figure 117: CMI Product with existing CATAnalysis 

 

Select the CATAnalysis in the product structure and use the Attach Archive function 
(see Handling of CMIArchives). 

 

The result is a new CMIArchive with the CATAnalysis file, CATProducts, CATParts, 
and the optional CATAnalysisResults file, which is attached to the existing item. 
Figure 118 shows the item with the new CMIArchive attached. 

 

Figure 118: CMIArchive item with CATAnalysis in Teamcenter 

 

The newly created CMIArchive can be opened with the CMI RII application (see 
Figure 119) and loaded to CATIA with the Read command. 
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Figure 119: CMI RII application with CMIArchive 

 

The result is the CATAnalysis document in CATIA V5 (see Figure 120). 

 

Figure 120: Existing CMIArchive with CATAnalysis loaded by CMI 

 

Changes made by the user can be updated with the standard CMI Update 
commands. 

 

If you only have the V5 GPS product but not a GAS license, you can still store a 
CATAnalysis in a CMIArchive. 

Your administrator should add the following settings to the CATIA environment: 

CMI_ENABLE_CRE_ANALYSIS_ARCHIVE=ON 

CMI_ANALYSIS_ARCHIVE_OWN_WINDOW=ON 

With these settings, you can create a CMIArchive out of the “Analysis Manager”. The 
second setting ensures that CATAnalysis opens in a separate window, even if the 
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CMIArchive is attached to an Assembly. 

 

Handling of CATProcess 

 

CATProcess is a CATIA V5 file type. In Teamcenter the CATProcess file can be 
imported to the CMI2Process dataset with the standard My Teamcenter functionality 
New→Dataset… (see Figure 121). 

 

Figure 121: Teamcenter New Dataset dialog 

 

After creating the CMI2Process dataset the dataset can be attached to an Item 
Revision. Figure 122 shows an example for a Process Element with a CMI2Process 
dataset. 

.  

Figure 122: Part with attached CATProcess data item 
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After sending the Process Element in the CMI RII application CMI will detect the 
attached CATProcess and changes the icon of the dropped Process Element. Figure 
123 shows an example for a Process Element in the CMI RII application window. 

 

Figure 123: CMI RII application with dropped Process Element 

 

After an expand of the Process Element in the CMI RII application the expanded 
items are by default marked as Product View Elements. Figure 123 shows an 
expanded structure. By default all child items of the Process Element are classified 
as Product View. By customization this can be enhanced to Product View and 
Resource View. The views are later used in the CATIA V5 module to define the View 
where the assembly should build in. 

After sending the CMI RII application content to CATIA V5 the CATProcess 
document is loaded in the CATProcess workshop of the CATIA V5 application. 

 

 

The Product View Assembly is build in the Product List. As described above, the 
adding of Assemblies to the Resource list can be customized in Teamcenter. Figure 
124 shows the opened CATProcess in CATIA V5. 
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Figure 124: Loaded CATProcess in CATIA V5 

 

Changes in the CATProcess document in CATIA can be updated with the Update 
command of CMI in CATIA V5. All documents in the ProductList and ResourcesList, 
which are loaded from CMI will also be updated. 

 

 
The handling of the CATProcess described above, will also work in the Structure 
Manager (PSE), but the icon for the Process Element will not change. 

 

Handling of Design Tables 

CATIA V5 Design Tables  can be stored in Teamcenter. Both CSV and Microsoft 

Excel files are supported. The Design Table dataset is linked to the Item Revision and to 
the CATPart. Design Tables referenced by CATParts and CATProducts are supported. 

Design Tables are not stored by default because of performance considerations; also, you 
need a sound methodology if you allow the use of Design Tables in your methodology, 
since Design Tables have the power to change your product structures. 

 

 
The Teamcenter administrator needs to set CMIWorkWithDesignTables to 1 in 

the Teamcenter preferences in order to enable the Design Table support. 

 

 
The CATIA administrator needs to set CMI_USE_DTFORPRODUCT=ON in the CATIA 

environment in order to enable the support of Design Tables and CATProducts. 
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Display Design Table 

 
To display the Design Tables in the CATIA structure the relation setting shown in 
Figure 125 must be set. 

 

 

Figure 125: CATIA setting for displaying relations in the structure tree 

Create Design Table 

 

For this use case an item was loaded from Teamcenter to CATIA. Then a Design 

Table was added to the CATPart with the CATIA Design Table command . 
Figure 126 shows the CATPart with the Design Table. 

 

Figure 126: CATPart with Design Table 
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In CATIA V5 please use the CMI Synchronize command. The dialog shown in Figure 
127 will show that the newly created Design Table will be created in Teamcenter. 

 

Figure 127: Synchronize dialog with create Design Table operation 

 

The Design Table is created in Teamcenter and linked to the CATPart. Figure 128 
shows the result from Teamcenter. 

 

Figure 128: Synchronize dialog with creation result from Teamcenter 

 

Figure 129 shows the result in the My Teamcenter application. The Design Table 
dataset is created and added to the Item Revision. 
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Figure 129: Design Table object in Teamcenter 

Update Design Table 

 

The Design Table can be changed in CATIA with a double click on the Design Table 
object. The dialog shown in Figure 130 will be opened. 

 

Figure 130: Edit Design Table dialog in CATIA V5 

 

With the Edit table … button an editor with the Design Table file is opened (see 
Figure 131). The radius is changed from 15 to 12.5 mm and the file is saved and the 
editor is closed. 
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Figure 131: Opened Design Table file 

 

CATIA will present the Knowledge Report (see Figure 132). 

 

Figure 132: Knowledge Report in CATIA V5 

 

The geometry of the hole is updated. Use the CMI Update  command in CATIA (see 
Figure 133) to save the changes in Teamcenter. 
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Figure 133: Changed Geometry in CATIA V5 

 

CMI RII will update the changed CATPart and Design Table file to Teamcenter and 
will show the success dialog (see Figure 134). 

 

Figure 134: Success message from Teamcenter 

Remove Design Table 

 

The Design Table can be removed in CATIA. Figure 135 will show the CATPart 
without the Design Table. 
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Figure 135: CATPart without Design Table 

 

After pressing the Synchronize command the Synchronize dialog is shown. The 
selected line shows the operation “Update/Drop child”. With the Info command the 
information for the deleted children will be displayed. 

 

Figure 136: Synchronize dialog before Drop operation 

 

The Synchronize command will remove the link from the CATPart (see Figure 137). 
The Design Table object is not removed from the item. The user has to check the 
status and if the Design Table dataset is not longer needed it can be removed in 
Teamcenter by the user. 
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Figure 137: Success dialog from Teamcenter 

 

Support of CATIA V5 Released Cache 

CMI supports the use of cgr files in the released cache of CATIA V5. For this purpose the 
cgr files of CATIA models are stored in Teamcenter. During To CATIA these cgr files are 
copied to the released cache instead of the CATIA models to the exchange map. In 
CATIA V5 the cgr files are loaded in visualization mode. 

 

Use Edit→Options to set the CMI RII preferences. 

Set “Transfer CGR file To CATIA” to “Only CGR” or “CGR + geometry” 

 

 

Use Tools→Options to set the preferences in CATIA V5. 

Set “Work with the Cache System” to “ON” and set the path to the released cache. 

“Check timestamps” must be “ON”. 

 

Figure 138: Tools→ Options dialog in CATIA V5 
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These are the necessary preconditions to copy a cgr file: 

• Work with the cache system in CATIA V5 is enabled. 

• The released cache is set and exists. 

• The CATIA V5 configuration variable CMI_USERELEASEDCACHE is set to 

“ON”. 

• The CMI RII preference “Transfer CGR-File to CATIA V5” is set to “Only 
CGR” or “CGR + geometry”. 

• A valid cgr file exists for the CATIA model in Teamcenter. 

 

 

If the CATIA V5 configuration variable CMI_SAVEADDITIONALCGR=ON is set, CMI 

RII stores a cgr file in Teamcenter whenever a CATPart is created or updated. 

 

Optional commands 

In the following section, optional commands are described which must be enabled by the 
administrator. 

SaveAs in Teamcenter 

 

 
To enable this function the administrator has to set the CATIA V5 environment 
CMI_REMOVE_CMISAVEASCMD=OFF. 

 

With this command a CATPart, CATDrawing or cgm currently set active in CATIA V5 can 
replace another file in Teamcenter. A CATPart, CATDrawing or cgm selected in 
Teamcenter and then dropped into CMI RII will be overwritten by the contents of the 
CATPart, CATDrawing or cgm in CATIA memory. 

 

Design or load your CATPart, CATDrawing or cgm in a separate window in CATIA. 

In CATIA V5 select the Save As in Teamcenter icon . 

 

Drag and drop or send an item into the CMI RII application in Teamcenter. 

In order to Save As in Teamcenter with a CATDrawing, drag the ‘new’ CATDrawing 
dataset to be overwritten into the CMI RII application in Teamcenter. The 
CATDrawing active in CATIA V5 will then overwrite its content. 

In order to Save As in Teamcenter with a cgm, drag the ‘new’ cgm dataset to be 
overwritten into the CMI RII application in Teamcenter. The cgm active in CATIA V5 
will then overwrite its content. 

In order to Save As in Teamcenter with a BOM CATPart, drag the ‘new’ item to be 
overwritten into the CMI RII application in Teamcenter. The CATPart active in CATIA 
V5 will then overwrite its content. 

In order to Save As in Teamcenter with a no BOM CATPart, drag the ‘new’ auxiliary 
dataset to be overwritten into the CMI RII application in Teamcenter. The CATPart 
active in CATIA V5 will then overwrite its content. 

 
Please take care when you Save As a CATPart which is used in a CATProduct a 
reference to the CATPart is stored within the parent CATProduct. Make sure that the 
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new CATPart is compatible. 

Update Position 

 

 

To enable this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_CMIUPDATEPOSITIONCMD=ON. This function updates only the 

transformation matrices in Teamcenter. The CATProduct and CATPart files are not 
updated. 

Update Part 

 

 

To enable this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_CMIUPDATEPARTCMD=ON. This function updates all modified CATPart 

files in Teamcenter. Transformations and CATProduct files are not updated. 

Restore Positions 

 

 

To enable this function the administrator has to set the CATIA V5 environment 
CMI_RESTORE_POSITION=ON. This function restores the positions to their original 

state loaded from Teamcenter. 

Choose Update Position 

 

To enable this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_UPDATEPOSITIONDIALOG=ON. This function is available for normal 

Update and the Update Position command. 

 

Figure 139: Choose Matrix To Update dialog 

 

If you have changed some positions in the CATIA session this function allows you 
to select the matrices to be updated. If you select a line in the dialog the 



 

106 CMI RII Release 4.9 - User Manual  

corresponding instance will be highlighted in the CATIA structure tree. 

• Yes → Matrix will be updated in Teamcenter 

• No   → Matrix will stay unchanged in Teamcenter 
To change the state you can double click a line or select the line and press the 
Toggle update state button. 

Choose Update Geometry 

 

To enable this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_UPD_MODELSELECT_DIALOG=ON. This function is available for 

normal Update and the Update Parts command. 

 

 

Figure 140: Choose Model To Update dialog 

 

If you have changed some geometries in the CATIA session this function allows you 
to select the models to be updated. 

• Yes → Model will be updated in Teamcenter 

• No   → Model will stay unchanged in Teamcenter 
To change the state you can double click a line or select the line and press the 
Toggle update state button. 

Revise 

 

 
To enable this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_CMIREVISECMD=ON. 

 

 

Select a CATPart or CATProduct item in CATIA you want to revise in Teamcenter. 

In CATIA V5 select the Revise in Teamcenter icon .  

 

The corresponding Item Revision is revised in Teamcenter and the Item Revision 
itself and the Item Revision children are updated in CATIA in the way a CMIRead of 
the same data would do it. That is, the metadata (ID, attributes etc.) is updated and 
structural changes are applied, but no modifications (geometry, position) are lost, 
and modified flags are preserved.  

A subsequent update will update the revised (reread) PDM objects and not the 
objects initially loaded. 
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Dataset pseudo Revise 

 

To enable this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_CHECKINOUTDLG_REVISEDATASET=ON. This function is available in 

the Check In/Out dialog. 

 

CMI RII supports the standard Teamcenter behavior for the revise process. That means 
when an Item Revision is going to be revised the CAD Datasets belonging to can be 
referenced by the new revision of the Item Revision (‘Copy As Reference’) or copied 
(‘Copy As Object’). With “Copy As Reference” the Dataset is write protected. 

In order to be able to modify the CAD Datasets in CATIA the CAD Dataset must be 
“pseudo Revised”. Though, a revise is only possible under certain conditions: 

• The CAD Dataset is referenced by a predecessor of the current Item Revision. 

• The Item Revision B has “working” state and the user has write access to the 
Item Revision. 

• If the CAD Dataset has “working” state a revise of the dataset is not required and 
will not be offered therefore. 

• Only primary CAD Datasets can be revised: CMI2Part, CMI2AuxPart, 
CMI2Product or CMI2Drawing. 

• Only CAD Datasets that are attached to an Item/Part can be revised. 
 

If these conditions are true then: 

• Creation of a new CAD Dataset /B. 

• Copy of the named Reference (the CATPart) from the CAD Dataset /A. 

• Copy of attributes from CAD Dataset /A. 

• Removal of Relationship between Item Revision /B and CAD Dataset /A. 

• The CAD Dataset /B will be attached to Item Revision /B. 

• Optionally (with CMI preference setting): Automatic Check Out of the new 
Dataset revision. 
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Figure 141: General Process of “Pseudo Revise” for CAD Datasets 

Automatic CATDUA 

 

 
To enable this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_CMICATDUAREAD=ON. 

 

To clean CATIA files that are stored in Teamcenter with the file based CATDUA utility you 
can use the Read with CATDUA command. 

 

The CMI CATDUAV5 integration needs a template configuration file to run 
CATDUAV5. The configuration file can be generated like described in the CATIA 
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documentation: “Using CATDUA V5 outside an interactive Session”. 

Use the procedure described in “Method 2: Accessing the Batch Interface from the 
CATUTIL / CATDUA V5 Batch Tool” to define the batch parameters (see Figure 
142). Make sure the “Document Selection” is empty. Save the configuration file to 
CMI_CATDUAV5.xml. 

 

 

Figure 142: CATDUAV5 parameter dialog 

 

The configuration file CMI_CATDUAV5.xml must be available on every client. 

The following variable must be set to point to the CATDUAV5 configuration file: 

CMI_CATDUAV5_CONFIG=<path>\CMI_CATDUAV5.xml 

 

 Use the icon  from the CMI toolbar to read the data that you want to clean. 

Select the cleaning method you want to use (see Figure 143): 

• “Clean Geometry Files” uses CATDUAV5 for all CATParts and 
CATDrawings to be loaded from Teamcenter. 

• “Clean Structure” uses CATDUAV5 for all CATProducts to be loaded from 
Teamcenter. 
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Figure 143: Cleaning Method selection dialog 

 

“OK” starts the Read from Workbench and launches the CATDUAV5 utility before 
loading the files. “Cancel” aborts the Command. 

After cleaning the files the result is shown in the web browser (see Figure 144), it 
can be found in the file 
%CMIXMAP%\CMI_CATDUA_Result_<YYYY><MM><dd><hh><mm><ss>.htm 

 

Figure 144: Global Results dialog 
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After inspection, you can update the cleaned files in Teamcenter. If you do not 
update, the changes made by CATDUAV5 are not stored. 
Note:  Cleaning files may take a long time. 
Attention:  For files that are already open, CMI RII cannot load the version that 

was cleaned by CATDUA. Make sure that you close the files that you 
want to clean. 

Verification of CATIA Release 

CMI can check the CATIA version of files against the current CATIA session during Read. 
This can be used to avoid loading a document from a newer CATIA release to an older 
CATIA version. The CATIA Release/SP/HF that was used to save a file in Teamcenter is 
stored in Teamcenter. 

To enable the check, the Teamcenter preference “CMIValidateCatiaVersion” has to be set 
to “1”. To store the Release Information in Teamcenter the Teamcenter preference 
“CMIStoreCatiaInfos” has to be set to 1. 

Representation Formats in CATIA V5 

 

The CATIA V5 module can be configured to support CATIA V5 shape representation 
files in a generic way. CATIA V5 Representation files can be used in a product 
structure and are handled in a similar fashion to V4 Models. 

 

 
With the following example settings the 3dmap, CATShape, and wrl 

Representation formats will be handled by the CMI RII CATIA Module. 

 

 

To enable support for specific Shape Representations, an administrator can set the 
following variable in the CATIA V5 environment: 

CMI_REP_FORMATS={3dmap}{CATShape}{wrl} 

 

 

The same formats must be enabled in the Teamcenter Options. 

Use Edit→Options to open the Teamcenter preferences dialog. 

Switch to the index tab and set the Preference CMIRepresentationTypeList to 

a String list with the supported formats like: 

• 3dmap 

• CATShape, and 

• wrl 

 

Figure 145 shows a wrl representation in the My Teamcenter application. 
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Figure 145: Representation formats in CATIA V5 (CATIA Workbench) 

Figure 146 shows the wrl representation loaded in CATIA V5. 

 

Figure 146: Representation formats in CATIA V5 

Import and  Export using a mapping file 

 

Set CMI_ENABLE_CREATE_IMPORT_FILE=ON in the CATIA environment to enable 

options in CMI Reconnect and Synchronize Teamcenter commands to map CATIA 
data that exists both in your PDM system and at a partner site, but under different 
naming conventions. 
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Synchronize 

Use the Write Import/Export mapping file option in the Synchronize dialog (see Figure 
147) to record or map original names for CATIA data that is stored in Teamcenter. 

 

Figure 147: Synchronize Dialog in CATIA V5 

As a result of the Synchronize a XML mapping file is created and attached to the top level 
assembly of the new structure in Teamcenter (see Figure 148). This file maps original 
names to Teamcenter names and will be used by the Reconnect and Export commands. 

 

Figure 148: Mapping File in Teamcenter 

You should also check this option if you receive a changed version of a structure that was 
imported, to update the mapping file with new subassemblies. 

Reconnect 

If a mapping file was created when the product structure was first imported into 
Teamcenter, this file can be used to map the CATIA names to the names the products 
have in Teamcenter. Click Use mapping file in the reconnect dialog (see Figure 149) to 
retrieve a mapping file that is attached to the top level part from Teamcenter. If a part was 
imported from outside, the internal name will be supplied by the mapping file. 
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Figure 149: Reconnect dialog in CATIA V5 

Export to Folder 

 

 
To enable this function the administrator has to set the CATIA V5 environment 
CMI_ENABLE_EXPORTCMD=ON. 

 
With the Export command you can save data that you have opened from Teamcenter to a 
folder of your choice. If a mapping file is available the products in the structure can be 
renamed to their original part numbers and file names. 

This allows you to return files that you have originally received from an external partner, in 
their original state. 

Start the Export with the Export to Folder button . 

CMI asks if you want to use the mapping file (see Figure 150). 

 

Figure 150: Ask use mapping dialog in CATIA V5 

• Yes: the structure is stored in the export directory using the original names of 
the CMI Mapping file. 

• No: The structure is stored into the export directory without renaming. 

CMI opens a folder selection dialog to select a directory where CMI should store the 
exported files (see Figure 151). 
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Figure 151: Export Location dialog in CATIA V5 

With “OK” CMI performs the export. 

After the structure is stored in the export directory CMI shows a summary about the 
renamed files. 

 

Figure 152: CMI Messages dialog in CATIA V5 

The export directory now holds the CATIA files of the exported structure and a CMI 
Mapping XML file which holds the actual mapping of between Teamcenter and the 
external structure. 

The files in the CATIA session are now “external” and can no longer be updated with CMI. 
The CATProducts and CATParts point to the external files in the export directory. The part 
numbers are set to the original part numbers stored in the CMI Mapping file. If 
CMI_EXPORT_STDATTRIBUTES was set the configured attributes Nomenclature, 
Definition, Revision or Description are also set back to their original values. 
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Glossary 

Administrator 

Person, who configures the system, inserts users, manages user permissions and 
maintains the database. 

Browser 

Window that displays icons representing objects. 

Check In 

Action that takes from the users the right to update a work item. 

Check Out 

Action that gives the user the exclusive right to update a work item. Checking out an item 
creates a copy of the work item in the specified work location. 

Configuration Context 

An attribute that determines which Item Revision should be displayed (for example, only 
the last revisions). 

Dialog Window 

Window in which the user enters information. 

Field 

Component of a dialog window in which the user can enter text. 

Generic Workbench 

Set of components such as windows, dynamic items and information items, used in 
Teamcenter integration products. 

Icon 

Graphical representation of an object. 

List View 

Style of browser window in which objects are viewed as small icons in a list with attribute 
values in columns. 

Object 

An item or relationship. 

Palette 

Any group of CATIA functions created for specific requirements. 
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Plot File  

File in a specified format that can be plotted or opened in a viewing tool and represents a 
2D view of a model. 

Pop-Up Menu 

The menu that appears when the user points an icon and holds the right mouse button 
pressed. 

Query  

To search the database for objects that match specific criteria. 

Register 

To make a file or directory known as an object maintained in the Teamcenter database. 

Tree View 

Style of browser window in which objects are displayed as relationships in horizontal 
branches. 

Vault 

Secure place for storing information. To access the data confined in a vault it is necessary 
to check out or revise the data. 


